1 Reply Latest reply on Feb 5, 2008 12:32 PM by joan_lafferty

    Opening swf files

    cinderedMonkey
      Hi.
      this has got to be some very simple config problem with my firefox.
      Every time i try to open an swf file I get an annoying dialog box of "You have chosen to open" <my flex file> "Which is a Shockwave Flash file" or something along those lines.
      It gives me an option of either opening it up with totem (a media player) or save to disk.
      I have installed flash player 9 for linux and it works since if I decide to open up with firefox (i.e. instead of totem I choose other, then navigate and manually pick /usr/bin/firefox to open the swf) my flex gui comes up properly (although the data is wrong).
      Why is this happening? It's annoying. Did I install flash incorrectly? Or Flex? Or both? Or what is more likely is that for some reason firefox isn't associating swf with flash. In which case...how do I fix this?

      Some notes:
      I'm running off Linux (Ubuntu 7.10), with Firefox (2.0.0.11), with Flex beta 3 SDK and flash player 9 for Linux
      Also, I'm trying to connect my Flex gui with a rails back-end with url
      localhost:3000/bin/<name>.swf

      Any help would be greatly appreciated.
        • 1. Opening swf files
          joan_lafferty Adobe Employee
          cinderedMonkey,

          First ensure that you have the Flash Player installed in Firefox. You can go to a site like adobe.com and be sure you see the animated swf playing. In FF, you can go to Tools-&amp;gt;Options-&amp;gt;Content and click on the &amp;quot;Manage...&amp;quot; button under the File Types group. This should bring up a dialog that shows what file types are associated with particular plugins. In my FF installation, I have the type SWF that has an action to open with Shockwave Flash.

          HTH,
          Joan Lafferty
          Flex SDK QA