5 Replies Latest reply on Feb 4, 2013 2:23 AM by C Kerr

    Baggage file not publishing in Single Source Layout

    raynerts
      I manage a project that has four Single Source Layouts that share a dozen baggage files between them. In one of the SSLs, six of those baggage files do not publish after being updated in the project; they publish just fine in the other SSLs. The new versions show up in the particular SSL when generated (via batch generate), but they don't publish (as part of a batch publish) and so I'm forced to manually drop the files into the destination folder. I cannot figure out why these guys will generate but not publish, and would only fail to do so in the one SSL.
      Thoughts?
        • 1. Re: Baggage file not publishing in Single Source Layout
          C Kerr Level 1

          Hi,

           

          I don't have a solution but I am experiencing the same problem. I have two single source layouts in my project. There is one PDF baggage file that is generated normally in one layout but it is missing from the other generated layout.

           

          One slight difference to the above is that I have not tried to publish either single source layout. This is happening when I locally generate by right clicking the layout.

           

          I know this is an old thread but I'd appreciate any ideas. Thanks.

          • 2. Re: Baggage file not publishing in Single Source Layout
            RoboColum(n) Level 5

            I have not heard of this happening before. Perhaps you could let us know what SSL is causing you the problem. Also it maybe useful to know what version of RoboHelp you have.

            • 3. Re: Baggage file not publishing in Single Source Layout
              C Kerr Level 1

              Hi Colum,

               

              Thank you for your speedy reply. Both SSLs in question (the one thatdoes generate the baggage file and the one that doesn't) are WebHelp layouts. I am using version 8.

               

              Many thanks.  

              • 4. Re: Baggage file not publishing in Single Source Layout
                RoboColum(n) Level 5

                Can you just confirm that the same file is being added as baggage to a project but that two WebHelp SSLs in that project are behaving differently? One is displaying the baggage file and the other isn't?

                 

                If this is a fair summary, can you tell us a little more about these SSLs. For example where are they generated too, do they have conditional build tag expressions, etc.

                • 5. Re: Baggage file not publishing in Single Source Layout
                  C Kerr Level 1

                  (Apologies for the delay in responding. I've been distracted by other things.)

                   

                  Yes, your first paragraph is a fair summary.

                   

                  They are generated locally to the C drive on my computer. They do have conditional build tags, with various differences between the two SSLs. There weren't any CBTs on the baggage file in question or the link to it though.

                   

                  I've experimented a bit and have now duplicated the link to the file and applied the CBT of one layout to one link, and the CBT of the other to the other link. After re-generating, the link is still broken in one of the SSLs. This suggests that the problem is with the file itself rather than the links. I have also changed the name of the file, still with no luck.

                   

                  Thanks for your help.