1 Reply Latest reply on Mar 2, 2008 4:05 PM by robdillon

    preloader problem

    Level 7
      I have always been using simple preloaders like "--------- 30%" but now I
      nead something more specific, and here is a problem..

      If I trace the percentage when the playhead is jumping from frame 1 to frame
      2 and vice versa until it's loaded for 100%, then I'm getting more than I
      expected:

      The traced results are:
      1 1 1 1 1 1 1 1 1 1 1 2 2 2 2 2 2 2 2 2 2 2 3 3 3..and so on

      instead of 1 2 3 4 5 ..and so on.

      I assume that it's because an animation is set to 30fps, and the playhead is
      jumping too fast and is able to "catch" more than one instance of 1% loaded
      while second % is loading.

      What I wanted to get:

      I wanted to have a function that would be increasing an _y position of the
      MovieClip by 5px every time the percentage rises by 10 percents, until it
      gets to 100%.

      So..
      when 10% are loaded, the function is trigered and the MovieClip's _y
      position increaes by 5px, and becomes 5px on Y axis (on the Stage).
      when 20% are done, moves another 5px and becomes 10px on Y axis (on the
      Stage).
      ..and so on.
      and when all 100% are done, MovieClip's _y position should be 50px on Y
      axis.

      But I'm getting about 23 instances of 10% (this way, the function that
      increases MovieClip's position is triggered 23 times), and as you can
      imagine, MovieClip moves to 115px co-ordinate on Y axis (instead of 5px).


      Thanks in advance!
      B.