1 Reply Latest reply on Mar 12, 2008 5:50 PM by nummsa

    An exception occurred when executing a COM method

    nummsa
      CFM:
      <cfset wwSales = createObject("com", "ww.main")>
      <cfset wwSalesReturn = wwSales.invoke("<func>getserverinfo</func>")>

      The ww.main COM+ service is setup properly - as far as I can tell. Global access with CreateOwner as "Everyone", tried leave running when idle, enabled idle shutdown, different owner rights, etc.

      produces the following error if the COM+ service was left idle for too long (i.e. 5min+)
      An exception occurred when executing a COM method.
      The cause of this exception was that: AutomationException: 0x800706be - .
      with the following callstack:
      AutomationException: 0x800706be -
      at com.linar.jintegra.NativeObjRef.nativeIDispatchInvoke(Native Method)
      at com.linar.jintegra.NativeObjRef.a(Unknown Source)
      at com.linar.jintegra.Dispatch.invoke(Unknown Source)
      at com.linar.jintegra.Dispatch.invokeMethodByName(Unknown Source)
      at coldfusion.runtime.com.ComProxy.invoke(ComProxy.java:578)
      at coldfusion.runtime.CfJspPage._invoke(CfJspPage.java:2261)
      at cfindex2ecfm944125949.runPage(C:\Inetpub\wwwroot\index.cfm:14)
      at coldfusion.runtime.CfJspPage.invoke(CfJspPage.java:192)
      at coldfusion.tagext.lang.IncludeTag.doStartTag(IncludeTag.java:366)
      at coldfusion.filter.CfincludeFilter.invoke(CfincludeFilter.java:65)
      at coldfusion.filter.ApplicationFilter.invoke(ApplicationFilter.java:279)
      at coldfusion.filter.RequestMonitorFilter.invoke(RequestMonitorFilter.java:48)
      at coldfusion.filter.MonitoringFilter.invoke(MonitoringFilter.java:40)
      at coldfusion.filter.PathFilter.invoke(PathFilter.java:86)
      at coldfusion.filter.ExceptionFilter.invoke(ExceptionFilter.java:70)
      at coldfusion.filter.ClientScopePersistenceFilter.invoke(ClientScopePersistenceFilter.java:2 8)
      at coldfusion.filter.BrowserFilter.invoke(BrowserFilter.java:38)
      at coldfusion.filter.NoCacheFilter.invoke(NoCacheFilter.java:46)
      at coldfusion.filter.GlobalsFilter.invoke(GlobalsFilter.java:38)
      at coldfusion.filter.DatasourceFilter.invoke(DatasourceFilter.java:22)
      at coldfusion.CfmServlet.service(CfmServlet.java:175)
      at coldfusion.bootstrap.BootstrapServlet.service(BootstrapServlet.java:89)
      at jrun.servlet.FilterChain.doFilter(FilterChain.java:86)
      at coldfusion.monitor.event.MonitoringServletFilter.doFilter(MonitoringServletFilter.java:42 )
      at coldfusion.bootstrap.BootstrapFilter.doFilter(BootstrapFilter.java:46)
      at jrun.servlet.FilterChain.doFilter(FilterChain.java:94)
      at jrun.servlet.FilterChain.service(FilterChain.java:101)
      at jrun.servlet.ServletInvoker.invoke(ServletInvoker.java:106)
      at jrun.servlet.JRunInvokerChain.invokeNext(JRunInvokerChain.java:42)
      at jrun.servlet.JRunRequestDispatcher.invoke(JRunRequestDispatcher.java:284)
      at jrun.servlet.ServletEngineService.dispatch(ServletEngineService.java:543)
      at jrun.servlet.jrpp.JRunProxyService.invokeRunnable(JRunProxyService.java:203)
      at jrunx.scheduler.ThreadPool$ThreadThrottle.invokeRunnable(ThreadPool.java:428)
      at jrunx.scheduler.WorkerThread.run(WorkerThread.java:66)

      The automationexception leaves no detail as to the error message with just " - .". If the COM+ service is not running at all or was just freshly shutdown, it can be instantiated and methods called just fine. I might consider attempting to call the constructor with the createObject().init() but haven't tested thus far.
      This is on a stock installation of Windows 2003 Server SP2 with CFMX8 + cumulative hotfix3.

      This same object served on a 2003 server pre-SP2 machine with CFMX7.0.2 seems to work perfectly fine, but the COM+ service never really goes idle with all the customer activity and automated health checking which loads this page every 1min.

      I cannot glean a single thing from the automationexception I'm getting as well as the lack of an actual message. I have not found any other cases of this exact error number. Nor have any of the proposed work-arounds with other COM instantiation methods worked either.

      Anyone, thoughts?
        • 1. Re:  An exception occurred when executing a COM method
          nummsa Level 1
          2 more things:

          1) As soon as I reload the page after this error - works perfectly fine. If I manually shut-down the COM+ running process via COM Services and reload the page - it works perfectly fine. It's only after this COM process has been running for a while and then still shuts down do I get this error when trying to run the CFM.

          2) It turns out that there is no constructor for this ww.main object, or at least reported by the CFDUMP.