7 Replies Latest reply on Nov 11, 2010 8:01 AM by Dave Watts

    CF service wont start after change to debugging settings

    bemall
      I changed two settings in my debug section with CF admin 8. Now I ma getting the error below, CF service will no0t start.
      Whats the best way to undo this, is there a file I can access to chnage cf settings. The settings I changed were with regard to debugging only.

      Log Name: Application
      Source: ColdFusion 8 Application Server
      Date: 1/15/2009 8:01:02 PM
      Event ID: 259
      Task Category: None
      Level: Error
      Keywords: Classic
      User: N/A
      Computer: MichelleGate
      Description:
      The ColdFusion 8 Application Server service could not be started. Check the server "coldfusion" log files for more information.
      Event Xml:
      <Event xmlns=" http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
      <Provider Name="ColdFusion 8 Application Server" />
      <EventID Qualifiers="49153">259</EventID>
      <Level>2</Level>
      <Task>0</Task>
      <Keywords>0x80000000000000</Keywords>
      <TimeCreated SystemTime="2009-01-16T02:01:02.000Z" />
      <EventRecordID>23126</EventRecordID>
      <Channel>Application</Channel>
      <Computer>MichelleGate</Computer>
      <Security />
      </System>
      <EventData>
      <Data>coldfusion</Data>
      <Data>ColdFusion 8 Application Server</Data>
      </EventData>
      </Event>
        • 1. Re: CF service wont start after change to debugging settings
          Level 7
          bemall wrote:
          > I changed two settings in my debug section with CF admin 8. Now I ma getting
          > the error below, CF service will no0t start.
          > Whats the best way to undo this, is there a file I can access to chnage cf
          > settings. The settings I changed were with regard to debugging only.
          >
          > Log Name: Application
          > Source: ColdFusion 8 Application Server
          > Date: 1/15/2009 8:01:02 PM
          > Event ID: 259
          > Task Category: None
          > Level: Error
          > Keywords: Classic
          > User: N/A
          > Computer: MichelleGate
          > Description:
          > The ColdFusion 8 Application Server service could not be started. Check the
          > server "coldfusion" log files for more information.

          Did you check the ColdFusion log files ? (#CF_HOME#/logs/ for server
          install).

          --
          Mack
          • 2. Re: CF service wont start after change to debugging settings
            BrienMalone Level 1
            I just got this same error while doing the exact same thing on my developer copy. We're going to have to go in and undo the configuration changes manually, but I'm not sure where to start... I'll post again when I figure it out.
            • 3. CF service wont start after change to debugging settings
              BrienMalone Level 1
              Okay -- got it.

              Turning on CFSTAT in the admin is what killed my server.
              Just FYI... I'm using 64-bit Vista with my CF8 installation.

              Edit the neo-metric configuration file
              c:\ColdFusion8\lib\neo-metric.xml

              (This file doesn't contain any formatting, so its best to open it with Dreamweaver or some other editor that will format the file to make it easier to read)

              Delete the following code:

              <var name='cfstat'>
              <string>true</string>
              </var>

              ...which should be located somewhere inside the coldfusion.server.ConfigMap struct.

              <wddxPacket version='1.0'>
              <header/>
              <data>
              <struct type='coldfusion.server.ConfigMap'>
              <var name='cfstat'>
              <string>true</string>
              </var>
              ...

              After deleting that entry, I was able to start the "ColdFusion 8 Application Server" without a problem.

              Here is a little extra information to help people who (like me) tried to Google this error.

              This was the exact message I received:

              Windows could not start the ColdFusion 8 Application Server on Local Computer. For more information, review the System Event Log. If this is a non-Microsoft service, contact the service vendor, and refer to service-specific error code 2.

              The system event log contained the following entry:

              The ColdFusion 8 Application Server service terminated with service-specific error 2 (0x2)
              Event ID: 7024

              The application event log contained the followign entry:

              The ColdFusion 8 Application Server service could not be started. Check the server "coldfusion" log files for more information.
              Event ID: 259

              Most solutions out there refer to extending the timeout period, but that had no effect for me.

              • 4. Re: CF service wont start after change to debugging settings
                ManojBinjola

                I am using CF 8 and it is crashing very often....

                Here is the log snippet...I am now to CF, any help or guidance will be truly appreciated.

                 

                11/11 05:55:14 info No JDBC data sources have been configured for this server (see jrun-resources.xml)

                11/11 05:55:14 info JRun Proxy Server listening on *:51800

                11/11 05:55:14 info Deploying enterprise application "Adobe_ColdFusion_8" from: file:/C:/ColdFusion8/

                11/11 05:55:14 info Deploying web application "Adobe ColdFusion 8" from: file:/C:/ColdFusion8/

                11/11 05:55:15 user JSPServlet: init

                11/11 05:55:15 user ColdFusionStartUpServlet: init

                11/11 05:55:15 user ColdFusionStartUpServlet: ColdFusion: Starting application services

                11/11 05:55:15 user ColdFusionStartUpServlet: ColdFusion: VM version = 11.2-b01

                11/11 06:07:49 info No JDBC data sources have been configured for this server (see jrun-resources.xml)

                11/11 06:07:49 info JRun Proxy Server listening on *:51800

                11/11 06:07:49 info Deploying enterprise application "Adobe_ColdFusion_8" from: file:/C:/ColdFusion8/

                11/11 06:07:49 info Deploying web application "Adobe ColdFusion 8" from: file:/C:/ColdFusion8/

                11/11 06:07:50 user JSPServlet: init

                11/11 06:07:50 user ColdFusionStartUpServlet: init

                11/11 06:07:50 user ColdFusionStartUpServlet: ColdFusion: Starting application services

                11/11 06:07:50 user ColdFusionStartUpServlet: ColdFusion: VM version = 11.2-b01

                11/11 06:09:49 info No JDBC data sources have been configured for this server (see jrun-resources.xml)

                11/11 06:09:49 info JRun Proxy Server listening on *:51800

                11/11 06:09:49 info Deploying enterprise application "Adobe_ColdFusion_8" from: file:/C:/ColdFusion8/

                11/11 06:09:50 info Deploying web application "Adobe ColdFusion 8" from: file:/C:/ColdFusion8/

                11/11 06:09:50 user JSPServlet: init

                11/11 06:09:50 user ColdFusionStartUpServlet: init

                11/11 06:09:50 user ColdFusionStartUpServlet: ColdFusion: Starting application services

                11/11 06:09:50 user ColdFusionStartUpServlet: ColdFusion: VM version = 11.2-b01

                11/11 06:11:11 info No JDBC data sources have been configured for this server (see jrun-resources.xml)

                11/11 06:11:11 info JRun Proxy Server listening on *:51800

                11/11 06:11:11 info Deploying enterprise application "Adobe_ColdFusion_8" from: file:/C:/ColdFusion8/

                11/11 06:11:11 info Deploying web application "Adobe ColdFusion 8" from: file:/C:/ColdFusion8/

                11/11 06:11:12 user JSPServlet: init

                11/11 06:11:12 user ColdFusionStartUpServlet: init

                11/11 06:11:12 user ColdFusionStartUpServlet: ColdFusion: Starting application services

                11/11 06:11:12 user ColdFusionStartUpServlet: ColdFusion: VM version = 11.2-b01

                11/11 06:11:16 user ColdFusionStartUpServlet: ColdFusion: application services are now available

                11/11 06:11:16 user CFMxmlServlet: init

                11/11 06:11:16 user CFMxmlServlet: Macromedia Flex Build: 87315.134646

                11/11 06:12:20 info No JDBC data sources have been configured for this server (see jrun-resources.xml)

                11/11 06:12:20 info JRun Proxy Server listening on *:51800

                11/11 06:12:20 info Deploying enterprise application "Adobe_ColdFusion_8" from: file:/C:/ColdFusion8/

                11/11 06:12:20 info Deploying web application "Adobe ColdFusion 8" from: file:/C:/ColdFusion8/

                11/11 06:12:21 user JSPServlet: init

                11/11 06:12:21 user ColdFusionStartUpServlet: init

                11/11 06:12:21 user ColdFusionStartUpServlet: ColdFusion: Starting application services

                11/11 06:12:21 user ColdFusionStartUpServlet: ColdFusion: VM version = 11.2-b01

                11/11 06:13:54 info No JDBC data sources have been configured for this server (see jrun-resources.xml)

                11/11 06:13:54 info JRun Proxy Server listening on *:51800

                11/11 06:13:54 info Deploying enterprise application "Adobe_ColdFusion_8" from: file:/C:/ColdFusion8/

                11/11 06:13:54 info Deploying web application "Adobe ColdFusion 8" from: file:/C:/ColdFusion8/

                11/11 06:13:55 user JSPServlet: init

                11/11 06:13:55 user ColdFusionStartUpServlet: init

                11/11 06:13:55 user ColdFusionStartUpServlet: ColdFusion: Starting application services

                11/11 06:13:55 user ColdFusionStartUpServlet: ColdFusion: VM version = 11.2-b01

                11/11 06:13:58 user ColdFusionStartUpServlet: ColdFusion: application services are now available

                11/11 06:13:58 user CFMxmlServlet: init

                11/11 06:13:58 user CFMxmlServlet: Macromedia Flex Build: 87315.134646

                11/11 06:13:58 user CFSwfServlet: init

                11/11 06:13:59 user CFCServlet: init

                11/11 06:13:59 user FlashGateway: init

                11/11 06:14:00 user MessageBrokerServlet: init

                11/11 06:14:01 user CFFormGateway: init

                11/11 06:14:01 user FlexMxmlServlet: init

                11/11 06:14:01 user FlexMxmlServlet: Starting Adobe Flex Web Tier Compiler

                11/11 06:14:01 user FlexMxmlServlet: Adobe Flex Web Tier Compiler Build: 184817

                11/11 06:14:01 user CFInternalServlet: init

                11/11 06:14:01 user FlexInternalServlet: init

                • 5. Re: CF service wont start after change to debugging settings
                  Dave Watts Adobe Community Professional

                  You've provided the service startup log, which doesn't really contain any useful information about why CF is crashing. It appears to be starting successfully, though.

                   

                  Your post title says "won't start" but your message says "crashing very often". Can you be more specific about what exactly is happening?

                   

                  Dave Watts, CTO, Fig Leaf Software

                  http://www.figleaf.com/

                  http://training.figleaf.com/

                   

                  Fig Leaf Software is a Veteran-Owned Small Business (VOSB) on

                  GSA Schedule, and provides the highest caliber vendor-authorized

                  instruction at our training centers, online, or onsite.

                   

                  Read this before you post:

                  http://forums.adobe.com/thread/607238

                  • 6. Re: CF service wont start after change to debugging settings
                    ManojBinjola Level 1

                    CF for me is crashing, please let me know what log I can fetch for more info?

                    Event Viewer:

                     

                    (APPLICATION)

                     

                    The Coldfusion MX 7 Application Server could not be started. Check the server
                    "coldfusion" log files for more information. Event ID: 259

                    • 7. Re: CF service wont start after change to debugging settings
                      Dave Watts Adobe Community Professional

                      Your previous message said CF 8, but here you're seeing CF 7 in your Windows event log. Do you have both installed? Can you uninstall CF 7? If you don't have service entries for CF 8, you can create them manually but it might be easier for you to just save your datasources and other settings and uninstall all versions of CF, and reinstall CF 8.

                       

                      Dave Watts, CTO, Fig Leaf Software

                      http://www.figleaf.com/

                      http://training.figleaf.com/

                       

                      Fig Leaf Software is a Veteran-Owned Small Business (VOSB) on

                      GSA Schedule, and provides the highest caliber vendor-authorized

                      instruction at our training centers, online, or onsite.

                       

                      Read this before you post:

                      http://forums.adobe.com/thread/607238