3 Replies Latest reply on Mar 15, 2019 2:30 AM by petarv18177047

    [iOS] Resource "*********" not found. Run 'pod install' to update the copy resources script.

    petarv18177047 Level 1

      Hey guys, how's it going?

       

      I'm having a problem trying to build an iOS package through Adobe PhoneGap Build  with a custom plugin (cordova-plugin-mobile-ocr - npm ) for iOS. This is the error I'm getting:

      PhaseScriptExecution [CP]\ Copy\ Pods\ Resources /Library/Developer/Xcode/DerivedData/TestOCR-aluvbdrrxvzobagsgrsuhdirkkqc/Build/Intermediates.noindex/ArchiveIntermediates/TestOCR/IntermediateBuildFilesPath/TestOCR.build/Release-iphoneos/TestOCR.build/Script-624FED8FD67C8546DDF75E06.sh     cd /project     /bin/sh -c /Library/Developer/Xcode/DerivedData/TestOCR-aluvbdrrxvzobagsgrsuhdirkkqc/Build/Intermediates.noindex/ArchiveIntermediates/TestOCR/IntermediateBuildFilesPath/TestOCR.build/Release-iphoneos/TestOCR.build/Script-624FED8FD67C8546DDF75E06.sh error: Resource "/Library/Developer/Xcode/DerivedData/TestOCR-aluvbdrrxvzobagsgrsuhdirkkqc/Build/Intermediates.noindex/ArchiveIntermediates/TestOCR/BuildProductsPath/Release-iphoneos/GoogleMobileVision/GoogleMVTextDetectorResources.bundle" not found. Run 'pod install' to update the copy resources script.  ** ARCHIVE FAILED **   The following build commands failed:      PhaseScriptExecution [CP]\ Copy\ Pods\ Resources /Library/Developer/Xcode/DerivedData/TestOCR-aluvbdrrxvzobagsgrsuhdirkkqc/Build/Intermediates.noindex/ArchiveIntermediates/TestOCR/IntermediateBuildFilesPath/TestOCR.build/Release-iphoneos/TestOCR.build/Script-624FED8FD67C8546DDF75E06.sh (1 failure) Error code 65 for command: xcodebuild with args: -xcconfig,/private/project/cordova/build-release.xcconfig,-workspace,TestOCR.xcworkspace,-scheme,TestOCR,-configuration,Release,-destination,generic/platform=iOS,-archivePath,TestOCR.xcarchive,archive,CONFIGURATION_BUILD_DIR=/private/project/build/device,SHARED_PRECOMPS_DIR=/private/project/build/sharedpch,-UseModernBuildSystem=0

      I am not sure how I can resolve this since yeah, I can't run any "pod" commands in the cloud build environment... or at least I don't know how.

       

      Can anyone help me with this problem?