1 Reply Latest reply on Feb 13, 2008 10:33 AM by lisa3711

    Windows Server - Mac Client Permission Issues?

    ShaneCF
      To start off, I'll summarize our current set-up. We've got Contribute Publishing Server running on Windows Server 2003. We have numerous Contribute clients spread out over our campus. They've all been using Windows XP. They connect via the LDAP settings in Active Directory. We're using Local/Network as our connection method. We have been encountering no difficulties using the software in this manner... at least until we tried installing the software on a Mac.

      We've currently tried two different Macs. The one in my office is OS X 10.4.9. I have successfully installed Contribute on it. The way we've been making people connect to our server is via Connection Keys. We learned that we could not use our old Connection Key, since it was created on a Windows platform. So, instead, I begin the process of setting up a manual connection.

      I enter our URL (we've actually been using an http://SERVERNAME address with Contribute) and tell it to connect to a Website. I enter Local/Network. I specify the mounted drive which appears as WWWROOT in the text box. I click Continue. Now it has me log in after telling me that the server is managed by CPS. It synchronizes some templates, which look kind of odd as it does so. In the file name listings as it works I see some ASP code. Not sure why, but it finishes and I see that our website has a connection established.

      I click the website name. It takes me to the home page. A bar appears at the top of the page. "You don't have permission to edit this page." Wait... what? I have full permission to edit everything when I log in elsewhere. In fact, on this Mac, every single page says this. I refresh the page and now it says "Contribute has disabled your connection to this website because an unknown error occurred." Hmm. I click the New button at the top... and I don't have access to any of the website's templates. In fact, I can't create anything. I hit the Connect button and it tells me "Access Denied. The file may not exist or there could be a permission problem."

      I'm at a loss for words. How/why could this be happening? Does anyone have any ideas?