5 Replies Latest reply on Feb 27, 2008 3:02 PM by shootathought

    RH7 Crashes When Adding a New Topic

    Feiya
      I am using RoboHelp 7 (not part of TechComm Suite). I created a brand new WebHelp project and created the template and .CSS file from scratch.

      Whenever I add a new topic to the project, it hangs for a minute and then crashes. When the project is reopened, the new topic has been created successfully but must be imported in order for it to show up in the topic list. The template uses a table to contain the topic information.

      I've looked around and was unable to find any similar support help topics. We copy the RoboHelp files from the network they are stored on to work on them on our Desktop because it is much much faster.

      Also, while I'm here, we also experience crashes with our snippets where it crashes pretty early on after importing the snippets and upon reopening, the snippets are gone, and we have to reimport them (though they are still in topics, as a blank line). I've seen a similar help topic on this issue, but haven't found a fix for it yet.

      I'm sure there's some vital information that I'm leaving out but I can't think of it at the moment.

      Thanks for your help!
        • 1. Re: RH7 Crashes When Adding a New Topic
          MergeThis Level 4
          You say: " We copy the RoboHelp files from the network they are stored on to work on them on our Desktop because it is much much faster." It's been well established in this forum that you must work with RH on your local machine.

          Given that, it also holds true that you must have all the project files available on your machine; I suspect that is not the case in your environment. That is, RH uses many under-the-cover files to keep track of all other files in its little project domain. It seems that RH is confused because it might be missing some important (to itself) project file(s).


          Good luck,
          Leon


          • 2. Re: RH7 Crashes When Adding a New Topic
            Feiya Level 1
            How can I make sure that I am copying all of the files of a project onto my local machine? I have RH installed on my machine and I copy the entire folder over. Also, this project is the only one I've had issues with the "adding a new topic crash."
            • 3. Re: RH7 Crashes When Adding a New Topic
              MergeThis Level 4
              Copy (check out) all files in the folder (.htm, .js, .apj, .hhc, hhk, etc.).

              You might also do a compare of the directory in source control and your local working directory (if you don't have software to do that, ask your IT peeps). There might be inconsistencies.


              Good luck,
              Leon
              • 4. Re: RH7 Crashes When Adding a New Topic
                Feiya Level 1
                I'm pretty sure the issue is that the template file is somehow corrupted. I ended up recreating the template in a new RH on my local machine and copying over the CSS file and it seems to be fine now.

                We will make sure that we make all of our changes to RH projects on our local machines from now on.
                • 5. Re: RH7 Crashes When Adding a New Topic
                  shootathought Level 1
                  We tried to do the same thing last year when I was still on RoboHelp 6. Repeated calls to tech support helped not at all. We had our web designer create a pretty new topic with a background and rounded corners and one big cel inside of it and for some reason RH just doesn't like those to be in topics! And trying to apply it to an existing topic was impossible.

                  The importing thing just wasn't an option for me, we ended up giving up. Wish i had found the answer, but I think it is something to do with the table in the template. Just doesn't like it.