6 Replies Latest reply on Apr 30, 2008 8:46 AM by Bookmark_Store_Error

    Bookmark Stored with Wrong Topic

    Bookmark_Store_Error
      I created a bookmark "AddFS" in a topic called "Funding Source." On the Hyperlink dialog box, I went to select the bookmark "AddFS" and it was not stored under "Funding Source" but under another, unrelated topic called "Funding Source Transfers." I tried deleting and re-entering the bookmark and hyperlink but problem was not fixed. I am using RoboHelp 7 and am a long time user of RoboHelp and have never seen this problem before.

      Is there a file were bookmarks and their respective files can be edited? The only fixes I can think of is renaming the original file to something that is not similar to the existing file; i.e., change "Funding Source" to "System Funding Sources." The other is to delete the "Funding Source Transfers" topic and re-create it.

      Is this a bug in RoboHelp 7?

      Elizabeth
        • 1. Re: Bookmark Stored with Wrong Topic
          Captiv8r Adobe Community Professional & MVP
          Welcome to our community, Elizabeth!

          This is a change that occurred with RoboHelp HTML 6 I think. If your topic is inside a folder it displays this way in the Hyperlink dialog. Try changing to the "All folders" view and it should look as you expect.

          Cheers... Rick
          • 2. Re: Bookmark Stored with Wrong Topic
            Bookmark_Store_Error Level 1
            Rick,

            I will try to make the issue clearer: I added a bookmark to one file but the bookmark is now listed as part of another file, which is the wrong file.

            Let's say I have a file called Funding Sources.htm. It has 2 bullets at the top: Add a Funding Source and Edit a Funding Source. In the same file are two corresponding tasks with the same names: Add a Funding Source and Edit a Funding Source. I put my cursor in front of the first task and insert a bookmark I call "AddFS." Then I select the bullet "Add a Funding Source" and try to add a hyperlink to "AddFS". What happens next is the problem: When I go to the Hyperlink dialog box and select the destination file, which is Funding Source, the bookmark "AddFS" is not there. It's under a different file with a different (but similar) name. So, when the user clicks on the bullet Add a Funding Source, the wrong file opens. I have tried deleting and re-inserting the bookmark but it still is getting saved to the wrong file. I hope the issue is clearer and you can help?

            Elizabeth
            • 3. Re: Bookmark Stored with Wrong Topic
              Captiv8r Adobe Community Professional & MVP
              Hi again Elizabeth

              Are you up for a desktop sharing session so that I may see first hand what you are describing? If so, shoot me an E-Mail to rstone75 (at) kc (dot) rr (dot) com and I'll send a link where we might connect and I can watch it in action.

              I'll be available for about another half hour to 40 minutes or so before I have to head out.

              Cheers... Rick
              • 4. Bookmark Stored with Wrong Topic
                Bookmark_Store_Error Level 1
                Yes, I'd like to try a desktop connection. I emailed you. Let me know if you do not get the email. My email is :
                istcerr (at) omh (dot) state (dot) ny (dot) us.

                Thanks
                Elizabeth
                • 5. Re: Bookmark Stored with Wrong Topic
                  Captiv8r Adobe Community Professional & MVP
                  Hi again

                  You should probably edit your post and remove your E-Mail address. If you leave it there, it's likely to become a spam magnet. :wiink;

                  Cheers... Rick
                  • 6. Re: Bookmark Stored with Wrong Topic
                    Bookmark_Store_Error Level 1
                    Your solution did solve the problem: Use Project Manager set to View by File Name and then add the hyperlink. When I select View by Topic Title and add a hyperlink, I see the bookmark listed under the wrong file. When I select View by File Name and add a hyperlink, I see the bookmark under the right file. This is definitely a change or perhaps a bug that wasn't in versions prior to RH 6.

                    Thanks very much for the help.