2 Replies Latest reply on May 15, 2008 7:40 AM by JuniperDan

    ELF CLASS error after mod_jrun22.so rebuild

    JuniperDan
      Installing CF8 multi-server on a Dell PowerEdge server (64 bit) running Linux Redhat Enterprise V5

      Installed XAMPP for Linux 1.6.6 (Apache 2.2.8, etc.)

      After running /opt/jrun4/bin/cf-connector.sh all goes well and the new module mod_jrun22.so is built and included into Apache's startup file httpd.conf, but when Apache attempts to restart, get the message below (the last few lines of cf-connector's log file at /opt/jrun4/Connectorinstall.txt).

      I have tried both the 32- and 64-bit versions of CF8, I've tried running wsconfig directly using the -ws32 switch. I now have about 25 copies of httpd.conf!!!

      If I understand the error correctly, mod_jrun22.so is being built as a 64-bit object and httpd is needing a 32-bit object.

      I have examined every instance of LD_LIBRARY_PATH in the source and build files to see if there is a 64-bit library referenced and haven't found any.

      I'm really hoping someone out there knows what I need to do to fix this.

      Thanks in advance!

      Dan Parchman, IT Technician
      Juniper Systems, Inc.
      www.junipersys.com

      Error message:
      ------------------------------------------------------------------------------------------ ---------
        • 1. Re: ELF CLASS error after mod_jrun22.so rebuild
          InfoCon_Brian Level 1
          I am running the ColdFusion developer's 64-bit edition version 8 on the same machine
          running Fedora, I got the same problem.

          I tried the Prerelease version. I notified the prerelease staff that I was getting
          a floating point exception, about two-three months ago.

          Apparently, the developers ignored the problem.
          • 2. ELF CLASS error after mod_jrun22.so rebuild
            JuniperDan Level 1
            Brian,

            I have learned that the compiler will build a 32- or 64-bit object depending on the ELFCLASS of the first module it uses during the compile, which in my (and yours, I suppose) case is 64 bits.

            The workaround I found: unzip the wsconfig.jar into a folder:

            cd %PathToColdfusion8%/runtime/lib
            unzip -d wsconfig_unzip wsconfig.zip

            Then navigate into wsconfig_unzip/connectors and find the prebuilt mod that you need. In my case it was at:
            wsconfig_unzip/connectors/apache/intel-linux/prebuilt/mod_jrun22.so

            Copy the mod to:
            %PathToColdfusion8%/runtime/lib/wsconfig/1/mod_jrun22.so

            Start (or restart) ColdFusion and you should be good to go.

            (By the way, in my earlier post I was running ColdFusion in multiserver mode [jrun]- I've since learned that since we purchased the Standard version instead of the Enterprise version that I should have been using the single-server version [coldfusion8])