8 Replies Latest reply on Nov 11, 2009 10:28 PM by Amebr

    RoboHelp building corrupt CPD files?

      My coworker and I are trying to get Visual SourceSafe up and running on her machine with RoboHelp so we can both work in the same help project. We've got it working great on my machine (I built the source control database from the help project on my machine). We got the files down to her machine, but when we open the help project, we get an error stating that the CPD file is corrupt and we should delete it and reopen the XPJ. We did that, and we got the message again, but when we looked at the directory to delete it, we found that RoboHelp didn't even rebuild the file. The error occurred before the file could be built.

      It appears that the CPD file does not reside out in the source control database. In other words, I have a working CPD file on my machine, but it does not get checked into the source control database. When we got her files the first time and opened them in RH, her RH tried to create a CPD file and was not able to do it successfully, so we got the error.

      Here's my solution and a further question: I copied the CPD file from my machine and sent it by e-mail to her, and we were able to open the help project and RH successfully retrieved topics from VSS. However, I wonder if there's something wrong with her RoboHelp? It looks to me like her RoboHelp is not able to build CPD files correctly. If that's so, can we expect other problems (maybe it won't be able to update the file correctly either)? Should we uninstall RH on her machine and reinstall it? If there's something wrong with RH on her machine, I'm concerned that we'll keep having problems after she starts making changes to topics.

      If anyone can help, I (we) appreciate it.

        • 1. Re: RoboHelp building corrupt CPD files?
          Peter Grainge Adobe Community Professional
          MergeThis can advise better but I do recall he has posted before that you don't check the CPD in. There are some other files like that but I don't have access to the note I made of those.
          • 2. Re: RoboHelp building corrupt CPD files?
            MergeThis Level 4
            HHP, CPD, PSS, LDB

            Good luck,
            • 3. Re: RoboHelp building corrupt CPD files?
              LRowan Level 1
              I'm sorry, obviously my message was too complicated. Rather than asking about what files I can check into source control, I was actually asking if there's something wrong with RoboHelp when it creates corrupt CPD files. Is this reason to uninstall RH and reinstall it, or was the problem fixed by supplying an uncorrupted CPD for the project created by a working RH.

              • 4. Re: RoboHelp building corrupt CPD files?
                MergeThis Level 4
                Rename/remove/archive the CPD and XPJ files, then double click the HHP file. RH will recreate fresh versions of those two files. This method also helps when the CPD file has simply gotten huge, not necessarily corrupt.

                Good luck,
                • 5. Re: RoboHelp building corrupt CPD files?
                  LRowan Level 1
                  Thank you, Leon! We'll give that a shot...

                  • 6. Re: RoboHelp building corrupt CPD files?
                    We are having similar problems with RH and VSS. It seems to be especially a problem on my machine - anything I do seems not be written to the VSS database. I noticed today that the CPD file version on my machine is out of sync with the database version. We have about 40 projects of varying size. However, the problem is not isolated to a single project or seem to be related to a specific-sized project. Certain projects work fine, and certain ones are consistently troublesome, and some give intermittant problems.

                    In one project, the CPD appears in the VSS database, and I must check it out from the VSS interface first (I finally got my local copy synced with the database). In another project, the CPD does not appear in the VSS database, and I'm not sure how to sync the two. To make matters worse, it appears that I don't have an HHP file in some of the local folders (there is an HHC and HHK file - but the HHP does appear in some local folders).

                    It appears to me that each of us has some local settings that are overriding the database settting - I can fix my local copy, and it will work fine until one of my co-workers opens it and makes a change. Then everything gets out of sync. The result is that I have to import missing files (they still appear in my local folder) or "unpurge" items in the database. The problem keeps recurring no matter what I do.

                    At one point, I fixed the project on my local machine, deleted the VSS version, uploaded the fixed project, and had my co-workers remove their local versions and re-downlead the new copy. It worked for a couple of weeks, but we're right back to having issues.

                    As far as I know, everyone always gets the latest version each time they open a project. We don't have administrative rights over the VSS database (we share the software with the developers), so we are limited as to what we can do, but the syncing problems are a serious issue. I've found several times that my work has been wiped out, and the constant re-importing topics, patching databases, and recreating work is has caused me to fall behind on my documentation projects.

                    Any assistance will be greatly appreciated.
                    • 7. Re: RoboHelp building corrupt CPD files?
                      MergeThis Level 4
                      Remove these local-machine-specific files from VSS: CPD. HHP, LDB, PSS. Keep them in your project folder, but do not check-in/check-out.

                      Good luck,
                      • 8. Re: RoboHelp building corrupt CPD files?
                        Amebr Level 4

                        I know this is old and marked as solved, but I thought I'd add this information here as it was the first topic returned in the search on "cpd is corrupt".


                        We started getting this message on a project we had copied to create a new project. It was confusing because the original project didn't suffer this problem, only the copied project.


                        After much searching we discovered it was because for the copied project, a blank rhvariable.apj file was created which didn't exist in the original project. (I assume because we deleted the cpd, pss and sss files and deleted the source control information out of the xpj file - not sure why it wasn't created when the project was upgrade to RH6 from X5...)


                        The solution to the problem was to add content from a working rhvariable.apj file. Voila, no more "the cpd is corrupt" messages.


                        The code for a blank variable file in RH6 is:


                        <?xml version="1.0" encoding="windows-1252"?>
                        <rhpml majorversion="1" minorversion="0">

                        Hope this helps someone in the future.