0 Replies Latest reply on Aug 23, 2006 11:41 AM by clint317

    CF/Flex Application Wizard Errors

    clint317 Level 1
      1. I ceated a CRUD application using the CF Application Wizard. I ran the finished application and everything seemed fine. Then I clicked the menu to the master page and an error displayed that it couldn't find the component specified (myapp.components.cfgenerated.Products). So knowing there's no mapping to myapp, I created it, even restarted the server, then tried it again. Still it didn't find it, why?. So I went into the code and added a known working mapping to the path, and it worked fine. Why am I having to change the coding of the app that the wizard created to enter the correct path to all of the references to these components? Why isn't the mapping I added working? Why isn't the wizard figuring out the correct mapping and path to its components or at least asking me for it?

      2. I want to re-use the wizard on an application I created. However, if I made any changes to the coding, these changes are not kept. So I assume that re-using the wizard on an application already created is only to get the initial design correct, PRIOR to any personal changes to the source. Is this a correct assumption?

      I like the wizard a lot and have put it to use but I can't stand having to search and replace all references to components to edit the path to the correct path and mapping to get it to work. And it would be nice if they included more controls to specify more design requirements such as box widths, grid heights, colors, fonts, etc..