0 Replies Latest reply on Aug 23, 2006 6:57 AM by xJuggalo

    XML parameters when consuming webservice

    xJuggalo
      I am trying to consume a .NET webservice.

      When I try to pass XML as a parameter on a function in the service, I get the following (for me at least) very strange error;

      Could not perform web service invocation "Book" because AxisFault
      faultCode: { http://schemas.xmlsoap.org/soap/envelope/}Server
      faultSubcode:
      faultString: Server was unable to process request. ---> Value cannot be null.
      Parameter name: uriString
      faultActor:
      faultNode:
      faultDetail:
      { http://xml.apache.org/axis/}stackTrace: AxisFault
      faultCode: { http://schemas.xmlsoap.org/soap/envelope/}Server
      faultSubcode:
      faultString: Server was unable to process request. ---> Value cannot be null.
      Parameter name: uriString
      faultActor:
      faultNode:
      faultDetail:

      Server was unable to process request. ---> Value cannot be null.
      Parameter name: uriString
      at org.apache.axis.message.SOAPFaultBuilder.createFault(SOAPFaultBuilder.java:260)
      at org.apache.axis.message.SOAPFaultBuilder.endElement(SOAPFaultBuilder.java:169)
      at org.apache.axis.encoding.DeserializationContextImpl.endElement(DeserializationContextImpl .java:1015)
      at com.macromedia.crimson.parser.Parser2.maybeElement(Unknown Source)
      at com.macromedia.crimson.parser.Parser2....

      This only happens when I try to use XML -anyone know what the problem is?