1 Reply Latest reply on Aug 22, 2006 10:39 PM by seth_hodgson

    Exception found .class

    K_G_
      I´m trying this site´s sample: http://weblogs.macromedia.com/dharfleet/archives/2006/07/integrating_jav.cfm#comments

      I have a problem running this. I´m using flex data service´s jrun server and when I run this, the server send me a exception and the TextInput still in blank.

      I have next tree:
      C:\fds2\jrun4\servers\default\flex\FDSWeb\WEB-INF\classes\fdsweb\EchoService.class

      and i have edit C:\fds2\jrun4\servers\default\flex\WEB-INF\flex\remoting-config.xml
      file, adding sample´s code.

      When I run the integrated flex server i can read next:

      error Could not pre-load servlet: MessageBrokerServlet
      [1]flex.messaging.MessageException: Cannont create class of type ´fdsweb.EchoService´. Type ´fdsweb.EchoService´not found.
      at flex.messaging. util.ClassUtil.createClass(ClassUtil.java:57)
      at flex.messaging.factories.JavaFactory$JavaFactoryInstance.getInstanceClass(JavaFactory.jav a:244)
      ...



      Someone can help me???

      Thanks
        • 1. Re: Exception found .class
          seth_hodgson Level 1
          Hi,

          Have you restarted your JRun server since dropping that .class file in WEB-INF\classes? Also, double check that you've added the class file to the correct web app. This error indicates that loading the "fdsweb.EchoService" class failed due to a ClassNotFoundException - so once you get that class on the web app's classpath you'll be fine.

          Best,
          Seth