1 Reply Latest reply on Nov 21, 2006 12:10 PM by spitch

    CFHTTP and SSL


      I am in the midst of migrating from BlueDragon to ColdFusion, and I ran across a problem connecting to a remote site via CFHTTP. I am posting XML to the remote site using formfield CFHTTPPARAMs. The code works in BlueDragon, and it works if I connect using http rather than https in ColdFusion (though I cannot connect using http to the production site for security reasons). I am running CFMX 7.02 on Windows.

      Attached is the code I use to post. Here is the response:

      Charset: [empty string]
      ErrorDetail: I/O Exception: Premature EOF encountered
      Filecontent: Connection Failure
      Header: [undefined struct element]
      Mimetype: Unable to determine MIME type of file.
      Responseheader: struct [empty]
      Statuscode: Connection Failure. Status code unavailable.
      Text YES

      I have tried importing the site's certificate into the \jrun4\jre\libs\security\cacerts file, thinking that the problem might be an unrecognized certificate, but that didn't help. The site's certificate was issued by Thawte Premium Server CA.

      Any suggestions? This could be a major problem with migration if I can't find a resolution.

      Thanks in advance for your help,

      -- Jim C.