0 Replies Latest reply on Jul 21, 2006 9:15 AM by phillips1021

    Flex 2 and ColdFusion NetConnection Failed

    phillips1021
      I'm posting a solution I had to a problem getting Flex 2.0 and Coldfusion to work together.

      I updated CF to CF 7.0.2. However, I could not get Flex 2.0 and CF to work together. I received netconnection failed messages whenever a Flex app tried to call a CFC function. The same app worked fine on my other development machine.

      After researching on google I found some posts that suggested the Java Virtual Machine (VM) used by ColdFusion must be higher than 1.4.2_05 for Flex2Gateway to work in CF. I checked the CF java settings on the machine with the problem. The Java VM Version was 1.4.2_05.

      I downloaded and installed JDK 1.4.2_10 and then changed the Java and JVM setting in the coldfusion admin to point to c:\j2sdk1.4.2_10\jre for the Java Virtual Machine path.

      I then restarted my computer and checked the settings in CF admin for the Java VM Version and it was now 1.4.2_10-b03.

      I re compiled my Flex app and ran it and it worked fine.

      So it appears for the Flex2Gateway to work correctly in CF the Java VM (virtual machine) must be higher then 1.4.2_05.

      If you are having problems getting Flex 2.0 and Coldfusion to work together, check your Java VM Version in ColdFusion Admin (System Information).
      Bruce