1 Reply Latest reply on Jul 25, 2006 3:12 AM by Newsgroup_User

    Dear Lord, Flash is stupid...please help me!

    Thatnickname Level 1
      Ok originally, I have this:

      1. on (release) {
      2. _root.current = 104;
      3. if(this==_level0.nav.contenus.nav.style.sub){
      4. this.container2.contenant.output.text = eval("_root.smenu"+1+"texte");
      5. }
      6. }


      which loads a text into "output". It works great. Now I have to load an image in another movie clip. So I add the line

      loadMovie(_root.smenu1image,this._parent._parent._ parent.introSwf);

      So it loads the image but the text that line 4 loads disapears...why???
        • 1. Re: Dear Lord, Flash is stupid...please help me!
          Level 7
          its a bit difficult following your MC's hierarchies, but my guess is that
          the image u load, is loaded into the MC in which your output text is, thus
          when the image is loaded it 'overwrites/replaces' whatever is in that MC.

          and btw - suggest choosing a more suitable subject line next time...


          "Thatnickname" <webforumsuser@macromedia.com> wrote in message
          news:ea36im$k02$1@forums.macromedia.com...
          > Ok originally, I have this:
          >
          > 1. on (release) {
          > 2. _root.current = 104;
          > 3. if(this==_level0.nav.contenus.nav.style.sub){
          > 4. this.container2.contenant.output.text =
          > eval("_root.smenu"+1+"texte");
          > 5. }
          > 6. }
          >
          >
          > which loads a text into "output". It works great. Now I have to load an
          > image
          > in another movie clip. So I add the line
          >
          > loadMovie(_root.smenu1image,this._parent._parent._ parent.introSwf);
          >
          > So it loads the image but the text that line 4 loads disapears...why???
          >
          >