3 Replies Latest reply on Sep 12, 2006 1:06 PM by HKabaker

    Subkeywords not functioning

      Uisng RHX5, I am generating both webhelp and html help, and this problem occurs in both formats.

      When I type a subkeyword into the index search box it is ignored. I can be looking right at the target expression in the index, but the search does not find it. I enter keywords and subkeywords both from the index tab in the project pane, and from the topic properties index dialog, but I don't think this makes a difference -- I cannot make ANY subkeyword work. Also, I tested this by creating a new topic and associating keywords and subkeywords to it using both methods.

      What could I be doing wrong?
        • 1. Re: Subkeywords not functioning
          RoboWizard Level 4
          Hi albizzia

          The only wrongdoing on your part is misunderstanding the way the Index and sub keywords work. We;;, that and possibly misunderstanding the differences between "Search" and "Index". But that's a discussion better left to a different thread.

          As you have seen, the Index field only causes the index to position to first level kewords. Sub keywords aren't positioned and don't factor into the mix. If you really want them to cause positioning, you need to promote them to first level entries. Or more likely, add them as additional first level entries. I do this all the time (having sub keywords as bot sub keywords AND first level keywords).

          Hopefully this helps... Rick
          1 person found this helpful
          • 2. Re: Subkeywords not functioning
            I see. So index subkeywords are not meant to work. Sigh. I guess I'll have to duplicate them all in the top level. What a job. Thanks, though - I don't blame the messenger.

            However, if you could offer help understanding the way the RH index works, which isnt really clear from their documentation, I would appreciate it. Perhaps there is an article somewhere you can point me to.

            - Carol
            • 3. Re: Subkeywords not functioning
              HKabaker Level 2
              (Never mind. I though I had a solution.)
              1 person found this helpful