6 Replies Latest reply on Sep 29, 2006 10:39 AM by JohnnyVic

    Clipboard Bug

    JohnnyVic

      After starting Word 2003 I can paste into the document a picture of the "Convert to PDF and Email" icon. So the problem seems to be that whenever I start Word this icon is placed into the clipboard (replacing whatever is currently in the clipboard). A very strange bug and quite annoying. Anyone else have this problem?

      This does not happen with Excel 2003 which has the same toolbar.
        • 1. Re: Clipboard Bug
          HKabaker Level 2
          In Word, close all files and click File|Open.

          For Files of type: select Document Templates (*.dot).

          Navigate to the templates folder and open Normal.dot.

          Click Edit | Office Clipboard.

          At the right, delete the red icon.

          This works for me, but I don't know if it's permanent.

          Harvey
          • 2. Re: Clipboard Bug
            JohnnyVic Level 1
            Tried the clipboard edit but the icon comes back the next time I start word.

            Does not come back when starting a blank document.
            • 3. Re: Clipboard Bug
              HKabaker Level 2
              I looked for info on how MS Word initializes the Office Clipboard. Word 2003 offers a lot of control over how it works, but I couldn't find anything on how to clear it in a way that prevents this strange corruption only when you first launch Word.

              I think I've solved it. So far I've closed and reopened Word several times, and the nasty icon is gone. Time will tell.

              First try this:
              Clear the clipboard and close Word.
              Open or create something in Notepad and save stuff to the clipboard.
              Launch Word and let it open a blank Document 1. Don't paste yet.
              Go to View and select Normal (rather than Print Layout).
              Open the clipboard with Edit | Office Clipboard. Does it show the icon or the saved text?
              From the Edit menu, click Paste. Do you get the saved text?

              Maybe you're still getting the icon.
              My last resort was to revise and re-save (Save As) the Normal.dot template with these conditions:

              The RoboPDF toolbar is not showing (but the menu, of course, appears).
              The blank template is in Normal view.

              Now when I launch Word 2003, Document 1 comes up in Normal view, the RoboPDF toolbar is not visible, and the clipboard contains whatever I put there since the last reboot. After a reboot, of course, the clipboard is empty.

              As I said previously, I don't know how long the fix will last.

              Harvey
              • 4. Re: Clipboard Bug
                JohnnyVic Level 1
                Thanks for all the effor Harvey.

                After following the first set of instructions the icon was still there and pasted into the document instead of the NotePad text.

                After the saving of Normal.dot the toolbar is still visible (paste problem still exists), the toolbar comes up and you can clearly see the icons being added slowly one by one until all three are there and then the RoboPDF menu is added. Not sure how it does that.

                Also, the PDF toolbar always comes up in the same position. I have tried saving a document with it in another position and then closing word but nothing helps.
                • 5. Re: Clipboard Bug
                  HKabaker Level 2
                  With Normal.dot open as a .dot file (not as Document 1), you see the PDF toolbar, right?

                  Click one of the down-triangle icons to show a dropdown that says

                  Show Buttons on One Row
                  ______________________

                  Add or Remove Buttons

                  Drag down to the lower one to see more options, and select "Customize."

                  (Microsoft sure hid this cleverly, didn't they?)

                  Click the toolbar tab. Check or uncheck toolbars of your choice, but particularly make sure 1-Step RoboPDF is not selected. Note that you can also suppress the PDFMaker toolbar here.

                  Close the dialog, and the toolbars should be as you want them. You can rearrange them. But to suppress or enable a toolbar upon opening a new Normal.dot or an existing *.doc, use the checkboxes.

                  Check the clipboard and clear it if necessary.

                  Save As ... Normal.dot.

                  Now any document that was built or attached to Normal.dot should open with the new toolbar configuration and a clear clipboard, or with all "collected" hunks of material from the current session, up to 24 items.

                  When you Exit Word and relaunch it (no reboot) at least one of the previously collected pieces should be there. (Why not all? I dunno.)

                  After a reboot, the clipboard should be empty.

                  Best regards,

                  Harvey
                  • 6. Clipboard Bug
                    JohnnyVic Level 1
                    Well finally that did it. I was able to remove the 1-Step toolbar and when Word restarted the toolbar did not appear and the paste problem was gone. Then I re-enabled the toolbar and it came up where I wanted and stayed there and the paste problem has not returned.

                    I found that Normal.dot would not saveas unless I made a change so I typed a character in the page and saved it and then deleted the character and did a saveas. Also strange is that Word is not prompting me if it is ok to overwrite any doc/dot file when using saveas. Same for other users in our office.

                    Yesterday I was resorting to saving as a different name and then exiting and renaming the file. So maybe the answer was typing/erasing the character to get the save to work or maybe the solution was only related to removing/re-adding the toolbar.

                    Thank you again for all the help.

                    Greg