5 Replies Latest reply on May 11, 2007 1:38 PM by ghostwriter62

    Cannot open chm file

    Sara_Writer
      Hi,

      I've found several threads on this site conserning error messages containing: mk:@MSITStore , but none of them seems to fit my situation.
      I worked in RH on a project, generated a new chm file a couple of times a day. No problem. Then suddently after generating another time I could not open the chm - not from within RH project, not from the folder, not when copying the (newly generated) chm to the desktop.
      The message is: "Cannot open the file: mk:@MSITStore:C:\Program Files\RoboHelp Office...\..\filename.chm"
      I've shortened it here with a couple of folders, but no it is not very deep. I'ts at the same level as my other projects, so that's not the problem.

      I can open older chm files generated from other projects as before, so there is nothing wrong with the help function itself. I've tried deleting the chm file, rebooting my pc, regenerating - but no result.

      I also tried the MJ's Diagnostics and the only problem found was:
      HTML Help 1.x Workshop Components*** HH Workshop not found or not installed correctly. Try reinstalling.
      But it seems like this 1.x is something very old and my installation has worked up until now. Do I really need to reinstall something and exacly what and how? Is this an RH component or MS component?

      Any clues are welcome.
      Thanks
      Sara


        • 1. Re: Cannot open chm file
          Level 2
          Sara,

          No, you shouldn't need to reinstall anything. The mk:@MSITStore is the protocol used for help files and the current help viewer is version 1, so that's not too old.

          My guess is that your .chm was somehow corrupted when you last compiled. When you compile do you get any error messages? Does the current file seem to be the right size? Can you open the .chm on another computer?

          Sorry - more questions than answers here.

          John
          • 2. Re: Cannot open chm file
            Sara_Writer Level 1
            Hi John,

            Thanks for trying to help out. It's solved now. I should have written the solution here right away, but I was so happy that I could continue with my work so I forgot about it.)

            What I did was that I looked at the single source layout and I thought that Optimize CHM File Size might cause a problem (a shot in the dark - but you have to try everthing). I deselected it and regenerated. Voila - it worked. Then, with trembeling hands, I selected it again and regenerated - it still worked. Maybe this change of the layout made it save again properly and restart from scratch. But i thought that I had tried a similar thing before when a made new layouts to see if they would work, and they didn't.

            So, it's solved, but I'm not really sure what was wrong and what solved it.

            Sara
            • 3. Re: Cannot open chm file
              ghostwriter62
              Hi,

              I also have this problem. I have 30 or so chm files that I have created and all open except one. I have tried all the things mentioned in this thread, including what's listed as the answer. Nothing has worked.

              Does anyone have any ideas? I have searched all over the place and cannot find any solutions.

              Any help greatly appreciated.
              • 4. Re: Cannot open chm file
                Captiv8r Adobe Community Professional & MVP
                Hi ghostwriter62

                Could it be as simple as the problem .CHM file being placed in a network location as opposed to the local PC?

                Just a thought... Rick
                • 5. Re: Cannot open chm file
                  ghostwriter62 Level 1
                  Sorry, I was offline for a couple of days.

                  No, the chm is in the same location (folder, even) as the other 30 or so chms.

                  Any ideas?