2 Replies Latest reply on Jul 20, 2006 10:32 AM by Newsgroup_User

    Flex 2 : Possible bug in Slider

    stchavan
      Hi,

      I have been trying to restrict the thumbs of an HSlider from overlapping.
      Setting allowThumbOverlap to false did not work.
      I noticed that the ability of the thumbs to overlap is directly related to the maximum value allowed for the slider.
      Given below is an example for the same. I presume this must be a bug, since the documentation mentions
      nothing about this. If somebody can throw more light on this, it would be great.

      TestSlider.mxml
      ===========================
      <?xml version="1.0" encoding="utf-8"?>
      <mx:Application xmlns:mx=" http://www.adobe.com/2006/mxml" xmlns="*">
      <mx:HBox>
      <mx:Label text="Maximum 13" width="90"/>
      <mx:HSlider id="slider13" width="180" thumbCount="2" snapInterval="1" minimum="0" maximum="13" dataTipPlacement="bottom" />
      <mx:Label text="Thumbs overlap in both directions" width="300"/>
      </mx:HBox>
      <mx:HBox>
      <mx:Label text="Maximum 14" width="90"/>
      <mx:HSlider id="slider14" width="180" thumbCount="2" snapInterval="1" minimum="0" maximum="14" dataTipPlacement="bottom"/>
      <mx:Label text="Thumbs overlap from left to right" width="300"/>
      </mx:HBox>
      <mx:HBox>
      <mx:Label text="Maximum 15" width="90"/>
      <mx:HSlider id="slider15" width="180" thumbCount="2" snapInterval="1" minimum="0" maximum="15" dataTipPlacement="bottom"/>
      <mx:Label text="Thumbs do not overlap" width="300"/>
      </mx:HBox>
      </mx:Application>
      ===========================

      Regards!

      Santosh
        • 1. Re: Flex 2 : Possible bug in Slider
          Kishan M V Adobe Employee
          Hi Santosh,

          We are keeping track of this issue.

          Thanks
          • 2. Re: Flex 2 : Possible bug in Slider
            Level 7
            Santosh,

            This is indeed a bug. Thank you for bringing it to our attention. As a
            workaround, try using different values for the width property or don't
            specify a width at all.

            --
            Jason Szeto
            Adobe Flex SDK Developer


            "stchavan" <webforumsuser@macromedia.com> wrote in message
            news:e9lh3m$sv0$1@forums.macromedia.com...
            > Hi,
            >
            > I have been trying to restrict the thumbs of an HSlider from overlapping.
            > Setting allowThumbOverlap to false did not work.
            > I noticed that the ability of the thumbs to overlap is directly related to
            > the
            > maximum value allowed for the slider.
            > Given below is an example for the same. I presume this must be a bug,
            > since
            > the documentation mentions
            > nothing about this. If somebody can throw more light on this, it would be
            > great.
            >
            > TestSlider.mxml
            > ===========================
            > <?xml version="1.0" encoding="utf-8"?>
            > <mx:Application xmlns:mx=" http://www.adobe.com/2006/mxml" xmlns="*">
            > <mx:HBox>
            > <mx:Label text="Maximum 13" width="90"/>
            > <mx:HSlider id="slider13" width="180" thumbCount="2" snapInterval="1"
            > minimum="0" maximum="13" dataTipPlacement="bottom" />
            > <mx:Label text="Thumbs overlap in both directions" width="300"/>
            > </mx:HBox>
            > <mx:HBox>
            > <mx:Label text="Maximum 14" width="90"/>
            > <mx:HSlider id="slider14" width="180" thumbCount="2" snapInterval="1"
            > minimum="0" maximum="14" dataTipPlacement="bottom"/>
            > <mx:Label text="Thumbs overlap from left to right" width="300"/>
            > </mx:HBox>
            > <mx:HBox>
            > <mx:Label text="Maximum 15" width="90"/>
            > <mx:HSlider id="slider15" width="180" thumbCount="2" snapInterval="1"
            > minimum="0" maximum="15" dataTipPlacement="bottom"/>
            > <mx:Label text="Thumbs do not overlap" width="300"/>
            > </mx:HBox>
            > </mx:Application>
            > ===========================
            >
            > Regards!
            >
            > Santosh
            >