8 Replies Latest reply on Oct 7, 2006 5:56 AM by lspec3

    Flash not working at all on Mac since upgrade!

    BC812
      I am very frustrated.... I am on a Mac, running version 10.3.9, and while visiting a website the other day I was told I needed a Flash upgrade. I went to the Flash site, downloaded and installed the update, and now Flash doesn't work on ANY website I visit. I keep getting this message: "[website name] has content of MIME type “application/x-shockwave-flash”, but you don’t have a plug-in installed for this MIME type." when I click "GO" to open the page where I'm supposed to download the plug-in, it takes me to the same place where I just downloaded the update from.

      I tried following the uninstall directions on the website, and that didn't work either. I downloaded and installed an update of Safari, which is the web browser I'm using, and still nothing. (Flash doesn't work in Explorer, either.) I'm admittedly not the best when it comes to troubleshooting things like this, but I am getting really frustrated!!!! No advice I am finding online seems to be the right thing. Any help would be greatly appreciated!!!!
        • 1. Re: Flash not working at all on Mac since upgrade!
          Rafiq Elmansy, AEL, ACP Level 2
          Hi,
          Make sure that you do not have 2 versions of Flash Player installed to your Computer. I could make conflects like this
          • 2. Re: Flash not working at all on Mac since upgrade!
            BC812 Level 1
            Thanks, I did make sure that I didn't have any older versions on my computer anymore. This solved the problem somewhat (ie, now my myspace.com background shows up when I look at my page, but the music doesn't play and most pages I visit still tell me that I don't have the necessary plug-in). I have done everything I know how to do, uninstalled, reinstalled, etc...... it's still not working as smoothly as it was a few days ago!
            • 3. Re: Flash not working at all on Mac since upgrade!
              Rafiq Elmansy, AEL, ACP Level 2
              Strange, this solution always works with me!!
              You may try to uninstall the Flash player and visit one of these sites that still require download it and when it ask to download the player go to the link they provide and download it.

              hope this helps
              • 4. Re: Flash not working at all on Mac since upgrade!
                Level 7
                Have you looked inside the /Library/Internet Plugins/ folder on your
                machine? This is where the Flash plugin lives. Perhap removing anything
                named Flash from there and reinstalling would do the trick.


                --
                John Pattenden
                Screentime Media
                Flash Screen Saver, Application and Wallpaper tools
                http://www.screentime.com

                • 5. Flash not working at all on Mac since upgrade!
                  BC812 Level 1
                  Thanks for all of your advice..... unfortunately I have tried following the links from certain websites that tell me I need the player, and they all take me to the same place where I continue to download from and install unsuccessfully :-(

                  I did delete EVERYTHING the other day with "Flash" in the name (I did a search on my computer). Then I re-downloaded Flash 9 and re-installed. As I mentioned before, this remedied the situation somewhat, but most websites still tell me I'm missing the plug-in (even though I am seeing more now than I was before on particular sites).

                  In my Library/Internet Plug-ins folder, the only thing that appears is a folder called Macromedia. Within that folder is another folder entitled Flash Player. And in the Flash Player folder, the only thing I see is a file called "version.txt" from June 22, 2006 (even though I installed it yesterday, September 4). When I do a search on my computer for "Flash," this same Flash Player folder is the only thing that shows up with the name Flash. This doesn't seem right to me, although I am not very computer literate when it comes to hardware and software problems so I could be completely wrong..... but shouldn't there be more to it?
                  • 6. Re: Flash not working at all on Mac since upgrade!
                    MMnovice
                    There are 2 libraries in OS X, one general and one specific to the user.

                    The library in your user account, the one you opened, should only have the version text. So that's correct on your computer.

                    If the plugin is installed correctly it's in the library you'll find on you HD, not inside Users. HD/library/internetplugins
                    • 7. Re: Flash not working at all on Mac since upgrade!
                      Level 7
                      Quite true, if it works on some sites then you must have it installed.
                      what OS version are you running? PPC or Intel? also you might try the
                      Reset and Flush cache options in Safari - look in the menus.


                      On 2006-09-06 01:01:30 -0400, "MMnovice" <webforumsuser@macromedia.com> said:

                      > There are 2 libraries in OS X, one general and one specific to the user.
                      >
                      > The library in your user account, the one you opened, should only have
                      > the version text. So that's correct on your computer.
                      >
                      > If the plugin is installed correctly it's in the library you'll find
                      > on you HD, not inside Users. HD/library/internetplugins


                      --
                      John Pattenden
                      Screentime Media
                      Flash Screen Saver, Application and Wallpaper tools
                      http://www.screentime.com

                      • 8. Re: Flash not working at all on Mac since upgrade!
                        lspec3
                        Not sure if this is still a problem, but I just solved it on mine. First, I eliminated anything "Flash" from the main library. Then I did not have sufficient privileges to install the new Flash (despite having Admin privileges). So i logged in as the root user (see Finder Help for this). Finally, re-installing Flash solved the problem.

                        Hope this helps.

                        --Leon