4 Replies Latest reply on Jan 8, 2007 1:36 PM by KEY_NYC

    Problem with Sample Application

    CKLThomco Level 1
      I downloaded the source code for the PhotoViewer sample app. When I open the project in Flex 2 Builder four(4)
      instances of an error appear : "Unable to resolve a class for ResourceBundle: strings" I googled and found a suggestion
      to "clean" the project which I did but still get the errors. I've tried this on 3 different workstations (with fresh downloadsand fresh installs of Flex and CF7.0.2) and all end up with the same error.
      Is it bad code ?
        • 1. Re: Problem with Sample Application
          Devin Holloway Level 1
          same exact problem
          • 2. Problem with Sample Application
            me three.

            PC / XP

            I am working with the sample app. photoviewer. I am gathering that it is a simple configuration of the locale file. I've created the new flex project (basic) by creating the project name photoviewer browsed to the folder i've extratcted to C:\Documents and Settings\........\My Documents\Flex Builder 2\photoviewer , (which also contains the locale folder).
            - main application file = PhotoViewer.mxml (Browsed to within folder).
            - Output folder = bin
            When I check the library path tab in this same "New Flex Project" window I can see that there is a ${FRAMEWORKS}\locale\{locale} path.
            I am guessing that this corresponds to the "Build.sh" file that contains this..

            # other locales are de_DE, fr_FR, and ja_JP
            OPTS='-use-network=false -library-path+=../../frameworks/locale/{locale} -source-path+=locale/{locale} -locale=en_US'
            ../../bin/mxmlc $OPTS PhotoViewer.mxml

            When I search for the "frameworks" file within my system I retrieve 3 instances;

            C:\fds2\flex_sdk_2\frameworks - this one contains both a locale and locale-fds folder.
            C:\Program Files\Adobe\Flex Builder 2\Flex SDK 2\frameworks - contains a locale folder with same files, but for a few.
            C:\cfusionFlexTFS\servers\cfusion\cfusion-ear\cfusion-war\WEB-INF\cfform\frameworks - has no locale folder, only contains an mx.swc.

            again, my project documents reside at C:\Documents and Settings\........\My Documents\Flex Builder 2

            I've also attempted to start the Build.bat but it just flashes for a moment and nothing happens.

            Within the Build.sh file I've tried changing use-network=false to true, changing the string ../../frameworks/locale{locale} and replacing the entire file with..
            %FLEX_HOME%/bin/mxmlc -use-network=false -library-path+=%FLEX_HOME%/frameworks/locale/{locale} -source-path+=locale/{locale} -locale=en_US PhotoViewer.mxml .. as suggested in a forum posting.

            I've tried pasting the sample locale file contents within the other 2 locale instances on my system and I've tried adding a locale file instance to the frameworks file that had none. I've tried starting Flex Data Services just in case, I've moved the files around within the project so that they are all in the same folder, removed the project, renewed the project. cleaned the project (which for some reason causes the .html wrapper to go unrecognized?).

            my error window reads;

            Error: Could not find resource bundle strings
            at mx.resources::ResourceBundle$/getResourceBundle()
            at CarouselView$cinit()
            at global$init()
            at _CarouselViewWatcherSetupUtil$/init()
            at mx.managers::SystemManager/::frameEndHandler()

            ..I would appreciate any advice.
            • 3. Re: Problem with Sample Application
              Add the following compiler arguments:
              -use-network=false -library-path+=locale/{locale} -source-path+=locale/{locale} -locale=en_US

              In Flex Builder, you can do this in Project->Properties->Flex Compiler
              • 4. Re: Problem with Sample Application
                KEY_NYC Level 1
                That did the trick.
                Thank you VERY much