0 Replies Latest reply on Sep 5, 2006 10:18 AM by csteinola

    Passing tree hierarchy to Flex from ColdFusion CFC

    csteinola
      Currently running Flex 1.5. Eventually we'll move to 2.0, which may or may not solve this issue... but for now...

      I'm building an app with Cairngorm, setting up ColdFusion CFCs as delegates for data backend, and I'm trying to create a hierarchy in one of the delegates to pass back into Flex for use as a dataprovider for a (standard) Tree control.

      So I produce an array of structs (objects), with or without children. The final node in a branch containing a data object with several attributes. The problem is that when that last node is displayed in the Flex Tree, it has a child element (ie - it's expandable) that contains an undefined object (presumably it's data object).

      I've tried various combinations of using _remoteClass = "Object", but I still get this phantom final node.

      As I've worked through this problem, I've gotten my test data down to a pretty bare minimum (hard-coded... just a single node with a child... see below).

      But when I set my Flex Tree's dataprovider to this array, I get the following display in the tree:

      + Node 1
      --+ Child 1
      ----+ [object Object], 1, , [object Object], null

      The odd thing is that the data does appear to be related correctly. In the tree, I can do treeMyTree.selectedNode.getData(), and get back an object with the proper keys "doctype", "docsku", etc. But in addition the tree thinks that the data should also be built out as a separate node.

      I've tried the same thing with no _remoteClass declarations, a _remoteClass on only the parent node, a _remoteClass only on the child node, etc... all with the same effect. I've also tried adding "ignoreWhite" as a key in each of the objects... didn't seem to do anything.

      Anyone know what I'm doing wrong?

      Thanks in advance,
      -Carl