2 Replies Latest reply on Sep 4, 2006 3:43 PM by icecappacino

    PopUpManager.createPopUp()

    icecappacino Level 1
      Hey,

      I have a movieclip hereforth known as "a" has a class attached to it that creates a PopUp. When running this movie the PopUp works fine. However when loading "a" into a movieclip hereforth known as "b"...it doesnt work.

      Running a trace on a reference to the PopUp returns as nul when running movie "b" while a will return a reference.

      What would cause the popup to work when running "a" initial yet result in "null" when loaded into "b"?

      Kendall
        • 1. Re: PopUpManager.createPopUp()
          injpix Level 3
          It sounds like a scope issue. Are you using “_root” anywhere in that class file? If so that would be an issue that can be fixed by replacing it by “this” or “_parent”. Also how are you creating an instance of this class? Are you doing it via the symbol or timeline? That would also be a possible problem. If you post the code it will reveal the problem.
          • 2. Re: PopUpManager.createPopUp()
            icecappacino Level 1
            myIP,

            quote:

            It sounds like a scope issue. Are you using “_root” anywhere in that class file?
            I was using "this" then i started using "_root"
            quote:

            Also how are you creating an instance of this class? Are you doing it via the symbol or timeline?
            I'm creating an instance of it from at runtime .It is executed from within a class's function that is attached to a movieclip. alertWindow results in null