2 Replies Latest reply: Sep 6, 2006 7:43 AM by brentil RSS

    Can't Run Any CFM pages After CF7 Upgrade

    Gary1 Community Member
      Was running CF5 on developer PC, WinXP, IIS, SQL Server with no problems. Went to upgrade to CFMX 7. So uninstalled CF5, did a clean install of CF7, Server Install, with IIS.

      Install went fine, but when asked to run the "Getting Started Experience" or "CF Administrator", Internet Explorer prompts me for UserID and Password (not the CF Admin password). Also, I can access any .HTML pages on my CFM web site, but when trying to access any .CFM pages, I get the same promt in IE, for a UserID and Password.

      Can anyone advise how to correct this? Seems I went through something similar 4 years ago when installing CF5, but can't remember the solution. Appreciate any help/advice, am totally frozen until I can access .CFM pages. Thank you.

      Gary
        • 1. Re: Can't Run Any CFM pages After CF7 Upgrade
          Gary1 Community Member
          Finally got the problem solved. I had a feeling it had something to do with NTFS security settings. I was missing one setting: I didn't have a "SERVER\USERS RX" setting in the C:\CFusionMX7 root folder. When I added this, I could run .CFM pages, and more importantly continue with the installation of the program where it "configures" the CF Web Server and installs the documentation in the "WEBROOT\CFIDE\GETTINGSTARTED" folder.

          Before this, I spent nearly 3 hours trying to "duplicate" the NTFS settings from a laptop I have, which is successfully running CF7. But I was focusing my efforts on the C:\Inetpub\wwwroot\cfide and other folders in the wwwroot section. I must have added/adjusted dozens of users, settings and authorizations (restarting the CF Server in SERVICES each time), but to no avail.

          It was only when I realized that the C:\CFusionMX7 folder was new (compared to the C:\CFUSION folder with CF5) and needed additional NTFS authorities. I added Administrators, myself, System, and a few others. But to no avail. It was only after performing many "searches" on these forums that I found an article where someone mentioned you needed to have a SERVER\USERS RX added to NTFS authorities in the C:\CFusionMX7 root folder. So when I added this, everything works, and I can run .CFM pages without getting prompted for a UserID and Password. The rest of the installation of CF7 finished, then I added the data sources, and we're up and running.

          WHEW, what a mess. I only wish the CF7 installation documentation covered some of these types of issues, which I'm sure a lot of people must deal with at some point. Anyway, all is well (for the time being). Thank you.

          Gary
          • 2. Re: Can't Run Any CFM pages After CF7 Upgrade
            brentil Community Member
            Just a note on this. Having the USERS group with permissions on the cfusionmx7 directory is a little more permissive then we would like so we've tried various other groups/users that are less likely to give unneeded permission access. During installation you can give the IUSR_servername & IIS_WPG account read/write to the inetpub & cfusionmx7 directory. Once installation is done you can remove the write permissions and leave just the RX permissions. However if you run into a couple other issues once you've locked it down like that there is another tech doc that refers to a dir inside of cfusionmx7 that might need write permissions.

            Here it is
            http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=a9eb1bad