2 Replies Latest reply on Aug 18, 2006 2:43 PM by frickin_chicken

    Failure to call a web service from deployed app

    dbrock@mw2consulting
      I have a Flex application which calls a web service running on IIS. If I run this application in the Flex IDE everything works fine. I then "deploy" it to the web server (the same one running the web service) and I see two different behaviors.

      1) If I access the application from my desktop (a different computer), then I get the following error:
      [RPC Fault faultString="Security error accessing url" faultCode="Channel.Security.Error" faultDetail="Unable to load WSDL. If currently online, please verify the URI and/or format of the WSDL ( http://webhost.mw2consulting.com/StatusCheck/ServiceCheck.asmx?WSDL)"
      at mx.rpc.soap::WSDLParser/::dispatchFault()
      at mx.rpc.soap::WSDLParser/ http://www.adobe.com/2006/flex/mx/internal::httpFaultHandler()
      at flash.events::EventDispatcher/flash.events:EventDispatcher::dispatchEventFunction()
      at flash.events::EventDispatcher/dispatchEvent()
      I did think that it might require a crossdomain.xml file, but I tried this on another server and it didn't make a difference.

      2) If I run it on the local machine (same one hosting the application) then I don’t get an error, but I see no evidence that the web service is being called (a button on the page is suppose to change color). Again, it does work when I run it from the development environment.

      Any ideas would be most appreciated!

      -David Brock-