0 Replies Latest reply on Sep 14, 2006 3:46 PM by winzurf

    Flash version detection in IE7

    winzurf
      FYI - I found that IE 7 was not responding to check for Flash version 9.*, kept telling me to upgrade - to fix this I changed the script AC_OETags.js to check for Flash 8 and 9

      try {
      // version will be set for 9.X or greater players
      axo = new ActiveXObject("ShockwaveFlash.ShockwaveFlash.9");
      version = axo.GetVariable("$version");
      } catch (e) {
      }

      if (!version)
      {
      try {
      // version will be set for 8.X or greater players
      axo = new ActiveXObject("ShockwaveFlash.ShockwaveFlash.8");
      version = axo.GetVariable("$version");
      } catch (e) {
      }
      }

      if (!version)
      {
      try {
      // version will be set for 7.X or greater players
      axo = new ActiveXObject("ShockwaveFlash.ShockwaveFlash.7");
      version = axo.GetVariable("$version");
      } catch (e) {
      }
      }

      Had the same problem with Opera 9 but this turned out to be a default security setting