3 Replies Latest reply on Sep 16, 2006 10:36 AM by Dr._Goomba

    Problem getting FDS and CF to communicate

    Dr._Goomba Level 1
      This has been an on going problem for almost a month now. As i gave up before, the more i learn about what FDS can do for me the more i want to use it. However it is just becoming the biggest pain to get it to talk with CF. I have read through the forums, walkthroughs and anything else i can get my hands on and still cant get it to work.

      The primary problem im encountering is:
      "Error invoking fill-method 'fill' for destination cfcontact-default: Permission denied."

      Coldfusion Config:
      Flex Integration: Flash Remoting enabled, Flex Data Management enabled, 192.168.1.150 allowed.
      All CFCs are located in wwwroot/contact_sample/samples/contact
      Mapping /samples -> C:\CFusionMX7\wwwroot\contact_sample\samples\
      http://192.168.1.150:8500/contact_sample/samples/contact/testContactAssembler.cfm returns 8 records

      Flex Config:
      Copied the coldfusion-dao adapter and the entire cfcontact-default destination from
      fds2\resources\config\data-management-config.xml
      to
      fds2\jrun4\servers\default\samples\web-inf\flex\data-management-config.xml
      AND
      Copied the cf-dataservice-rtmp, cf-polling-amf channel definitions and the DataService.coldfusion pattern from
      fds2\resources\config\services-config.xml
      to
      fds2\jrun4\servers\default\samples\web-inf\flex\services-config.xml
      I did nothing else, no changing {server.name} or uncommenting <hostname>.

      My application files are installed at: C:\fds2\jrun4\servers\default\samples\contact_sample\dataservice\contact
      And i run the application from: http://192.168.1.150:8700/samples/contact_sample/dataservice/contact/contactmgr.mxml
      I did not change the directory structure or edit any of the files within the contact_sample zip file.

      NOTE: both data-management-config.xml and contactmgr.mxml both reflect cfcontact-default

      I have gone through these files over and over and over, messed with other things, reinstalled, everything! I dont know what else to do. Help is greatly appreciated!!!
        • 1. Re: Problem getting FDS and CF to communicate
          Bill Sahlas
          let's see if I can help you out. That permissions error is usually related to RMI registry having no knoledge of the IP address. On the FDS server installation the sample data-management-config.xml file has a section has a section that shows that you need to specify the <hostname> attribute of the properties elements section. I didn't see that mentioned in the list of things that you configured or modified or checked - I see that you allowed it on the CF side (admin settings) but not on the Flex side. The sample resource file is located at fds2\resources\config\ folder.

          <!--
          The hostname or IP address of the CF host.
          Optional, default is localhost.

          <hostname>localhost</hostname>
          -->

          • 2. Re: Problem getting FDS and CF to communicate
            Bill Sahlas Level 1
            point of clarification - set the <hostname> to match what you've added to the Allowed IP list in the cf admin, 192.168.1.150. Setting this attribute is an all or nothing type of setting - if you set it on CF then you need/must set it on the Flex side. the use-case for this is if you've got CF on Server1 and FDS on Server 2 - this is how you tell each instances what IP addresses are allowed to communicate. If both instances of CF and FDS are on localhost - *leave that attribute alone* in both places as localhost is allowed by default.
            • 3. Re: Problem getting FDS and CF to communicate
              Dr._Goomba Level 1
              Thanks for your response!

              I have tried two different ways to go about this, using localhost and defining an IP. Neither work.

              NOT DEFINING THE IP
              - In data-management-config.xml i left the hostname commented, since default is localhost.
              - In CF Admin Flex Integration i removed my IP address and saved it.
              - Then loaded: http://localhost:8700/samples/contact_sample/dataservice/contact/contactmgr.mxml

              DEFINING THE IP
              - Uncommented <hostname> and added 192.168.1.150 in data-management-config.xml
              - Added 192.168.1.150 to CF Admin Flex Integration
              - Then ran http://192.168.1.150:8700/samples/contact_sample/dataservice/contact/contactmgr.mxml

              Both instances return the permission denied while invoking fill-method for cfcontact-default error.

              I have noticed that when Flex Server reloads there is an error stating "Requested resource 'samples/messagebroker/cfamfpolling' (%2fsamples%2fmessagebroker%2fcfamfpolling) not found"

              I have not specified Port Numbers in any of these configurations. Flex is on 8700 and Web Server on 8500. Also note that services-config.xml does not list any IP's or Port's unless the Port number was specified in the 'samples' xml file.

              Other ideas?