8 Replies Latest reply on Jul 31, 2006 8:21 AM by dukerickroot

    Problem accessing web service, error 2032 Stream Error

    RicRoot
      I'm building a small flex app hat uses two web services provided by the same coldfusion CFC.

      I've verified that I can successfully access the web services via HTTP, and one of the web services actually does work when called. Both return structures that contain a string var, a numeric var, and one or more query vars.

      Here is my web service declaration:

      quote:

      <mx:WebService id="ws"
      wsdl="https://www.it.dev.duke.edu/components/dukemagsearch/checkMailing2.cfc?wsdl"
      useProxy="false">
      <mx:operation name="queryDB" result="queryDBResult()" fault="queryDBFault(event)">
      <mx:request>
      <RUNDATE>{cboRunDate.selectedItem.XDATE}</RUNDATE>
      <ENTITYID>{txtEntityID.text}</ENTITYID>
      <LASTNAME>{txtLastName.text}</LASTNAME>
      <FIRSTNAME>{txtFirstName.text}</FIRSTNAME>
      <MINITIAL>{txtMiddleInitial.text}</MINITIAL>
      <PRFSCHCD>{cboPreferredSchool.selectedItem.TABLKEY}</PRFSCHCD>
      <PRRECTYP>{cboRecordType.selectedItem.TABLKEY}</PRRECTYP>
      <PRFCLASS>{txtPreferredClass.text}</PRFCLASS>
      </mx:request>
      </mx:operation>
      <mx:operation name="getListData" result="getListDataResult()" fault="getListDataFault()"/>
      </mx:WebService>



      Sorry if the formatting sucks, I don't know how to post "code" here.

      Anyway, the getListData() method works fine and populates my list boxes. But when I call the queryDB() method, I get the following fault event:

      quote:

      [FaultEvent fault=[RPC Fault faultString="HTTP request error" faultCode="Server.Error.Request" faultDetail="Error: [IOErrorEvent type="ioError" bubbles=false cancelable=false eventPhase=2 text="Error #2032: Stream Error. URL: https://www.it.dev.duke.edu/components/dukemagsearch/checkMailing2.cfc"]. URL: https://www.it.dev.duke.edu/components/dukemagsearch/checkMailing2.cfc"] messageId="1E553B99-DF28-ED72-62B8-B84AA3919F9A" type="fault" bubbles=false cancelable=true eventPhase=2]


      I've looked all over the place and I can't seem to find what this error means. I've tried all kinds of different ways of doing things. Right now I'm browsing the flex app via a file URL (C:\...) but I tried putting it up on the server too and that didn't work either.

      The method call *DOES* work when called via HTTP... ie

      https://www.it.dev.duke.edu/components/dukemagsearch/checkMailing2.cfc?method=queryDB&RUND ATE=2006-05-19&FIRSTNAME=&LASTNAME=SMITH&MINITIAL=&PRFSCHCD=&PRRECTYP=AL&PRFCLASS=&ENTITYI D=

      (You have to be logged in for that to work so you'll just have to trust me, it returns no records if you're not logged into the web site already).

      I'm totally stressing out about this because I've essentially spent the entire day since 8am trying to solve this. The application should've taken 15 minutes total.

      HELP!

      Thanks for any suggestions y'all have.

      Rick