8 Replies Latest reply on Jul 2, 2006 8:58 AM by Peter Grainge

    Last TOC book does not expand

    JanetSwisher
      I have a WebHelp project in which the last book in the TOC does not expand. The icon switches from closed to open, but the contained books and topics do not appear. I see the same behavior in IE and Firefox on Windows, and Mozilla on Linux.

      The contents of the TOC up to that point are defined in whxdata/whtdata0.xml in the generated output. In that file, the tag for the last book (whose title is "Reference") contains a reference to the "next" XML:

      <book name="Reference" >
      <chunk name="Reference" ref="whtdata1.xml" />
      </book>

      The file whtdata1.xml exists and contains the data for what should be the contents of the "Reference" book.

      Any clues for why the referenced data is not being displayed?

      Janet Swisher --- Senior Technical Writer
      Enthought, Inc. http://www.enthought.com
        • 1. Re: Last TOC book does not expand
          Peter Grainge Adobe Community Professional (Moderator)
          Just a hunch.

          Delete the book. Generate the help. Add the book and topics. Generate the help.

          Or perhaps you have already tried that?

          • 2. Re: Last TOC book does not expand
            JanetSwisher Level 1
            Thanks for the suggestion, Peter. I just tried it, and it did not help.

            FWIW, this project is a merged project, in which I use your TOC links technique to create the TOC in the parent project, as we have corresponded about previously. So I go into whtdata*.xml to change "..\mergedProjects" to ".\mergedProjects", and to flip the path separators. But I don't see that that should make a difference for this problem.

            --Janet
            • 3. Re: Last TOC book does not expand
              Peter Grainge Adobe Community Professional (Moderator)
              I thought I sent a reply to the effect that changing the path level should not be necessary, assuming that is you have followed my merge method. I do remember the emails but sorry I cannot recall the detail or locate them right now.

              The fact that this problem only occurs in the last book makes me wonder if something in the wh file is not correct.

              Try and create this book in a place other than the end and see what happens.

              If that does not change anything, create a mini merged set up and try recreate the problem there. Let me know how that goes.

              • 4. Re: Last TOC book does not expand
                JanetSwisher Level 1
                Hi Peter,

                The change I mentioned is the one you prescribe making in whtdata0.xml. (The change you didn't think was necessary in a well-formed project was changing "../../mergedProjects" to "../mergedProjects" in whgdata/whlstt*.htm.)

                I tried moving the "last" book earlier in the TOC. Now the failure occurs on a different book, but still the one that ends up in whtdata1.xml. So the issue is not with it being last; the issue is with it being a book that is defined in another file, rather directly than in whtdata0.xml. (It was just a coincidence that is was last previously.) I now have several books that end up in later whtdata files, and they all have the same problem.

                I will try to reproduce the problem starting with your example merged project, and report back.

                --Janet
                • 5. Re: Last TOC book does not expand
                  Peter Grainge Adobe Community Professional (Moderator)
                  Janet

                  If you would like to set up a project with this problem, then zip it up and send it to me I will take a look but it will not be until next week. Ordinarily I would offer to take a look at it over the weekend but we are going away straight after I finish work.

                  I've just reread my topic so I see why you changed the level now. Sorry I had forgotten that. I've also tracked down your email of 14/6 with the details of the changes you made.

                  If the only way to show me the problem is to send your full project that will be OK but if zipped it is more than 5mb or so, don't email it. Let me know and I will send you some FTP instructions.

                  • 6. Re: Last TOC book does not expand
                    HKabaker Level 2
                    Janet,

                    When I have a problem like this, sometimes I find a very tiny error in syntax. So if you haven't already gone back there, I would suggest you do so.

                    I have this situation:
                    Opening in an XML editor such as FAR, in "whtdata0.xml" I see this reference:

                    - <book name="Database tables">
                    <chunk name="Database tables" ref="whtdata1.xml" />
                    </book>
                    . . . . etc.

                    File "whtdata1.xml" starts like this:

                    <?xml version='1.0' encoding='windows-1252' ?>
                    - <tocdata>
                    <item name="Introduction" url="introduction.htm" />
                    - <book name="aaaa tables">
                    <item name="APP_ROLE" url="aaaa/APP_ROLE.htm" />
                    <item name="APP_USER" url="aaaa/APP_USER.htm" />
                    <item name="APPLICATION" url="aaaa/APPLICATION" />
                    <item name="DOMAIN" url="aaaa/DOMAIN.htm" />
                    . . . etc

                    The hyphens don't show up in Notepad or TextPad. Is it missing in your file?

                    Harvey
                    • 7. Re: Last TOC book does not expand
                      JanetSwisher Level 1
                      I've figured out what is causing this problem, but not how to really fix it.

                      It is caused by a change I made to fix a different problem, of the navigation pane being truncated in Linux Mozilla. I made the change described in this KB article: The navigation pane appears truncated when accessing a WebHelp project using Mozilla

                      That workaround involves changing a 'height' attribute from '"+parent.height+" 'to '100%'. When I apply the workaround, books defined in later files than whtdata0.xml do not expand. When I leave the height parameter alone, I get a short navigation pane, but the books expand properly. The problem is apparently with using a %-based value; if I set it to '50%', I get the worst of both worlds.

                      Any clues to how I can have my cake and eat it too -- that is, expand my TOC and see it too?

                      --Janet


                      • 8. Re: Last TOC book does not expand
                        Peter Grainge Adobe Community Professional (Moderator)
                        Not without a project that has this problem.