13 Replies Latest reply on Aug 4, 2006 12:19 AM by safaman

    problem   sos panic!!!!!!

    safaman
      new to flex
      i went on http://www.adobe.com/devnet/flex/quickstart/using_controls/
      copied some of those exmaples and pasted them onto flex .when i see it i design mode it looks like the one on adobe site but when i save and run it, it shows me a blue screen with absolutely nothing on it.

      also i have some files form total training tutorial and when i change something it shows the changes in design mode but when saved and run it , it does not register my changes and shows the same thing as if i never had change anything
      can somebody help????
        • 1. Re: problem   sos panic!!!!!!
          leotemp Level 1
          More then likley there are errors in the document, make sure you have the errors and warnings dialog displayed its called "problems" and can be viewed by clicking "Window" and then "Problems", anything listed with a red circle and white X through it is a fatal error that has to be resolved before the flash file can be compiled. Flex builder will act like it saved your file but in reality i think its just running the course of its "Building workspace" routine, you must fix or comment out the error in order to compile.

          To fix an erorr douple click on it in the "Problems" dialogue while viewing the document in source mode, it will take you to the offending line, to comment out the code put // before the first character on the line, other then that i cant tell you without something posted.

          leo
          • 2. Re: problem   sos panic!!!!!!
            safaman Level 1
            thanks for the resposnse leotemp
            i got some files that are from totalTraining and they work but when i comment out some of its stuff or chang the sizes(width or height or in one instance i deleted the line for the header picture and compiled it and it sitll showed the same file like no changes wrere done).
            it does not even show any error
            thanks
            • 3. Re: problem   sos panic!!!!!!
              ntsiii Level 3
              Make sure you have "Build Automatically" checked under the Project menu.

              Tracy
              • 4. Re: problem   sos panic!!!!!!
                leotemp Level 1
                And make sure your default application is the one you want (rigth click, select default application) also, i have asked about this in another thread, sometimes i have to shutdown flex builder, uncheck "read only" on the bin folder, restart flex and recompile.. why? im not sure, probably the same reason i have to do this everytime i want to update any file in that folder..
                • 5. Re: problem   sos panic!!!!!!
                  safaman Level 1
                  hello again leotemp
                  you said " make sure your default application is the one you want (rigth click, select default application)", do you mean at the beginning to right click new>flex project>and go through naming and ....?

                  you said also" , uncheck "read only" on the bin folder"how do you uncheck it .

                  i uninstalled felx and reinstalled and opend a simple file and changed the backgroundColor and it shows the change in design view but afer running it ,is still the blue screen and also imported a picture which also shows in design but not in runTime

                  also project>build Automatically, is also checked
                  thanks very much for help
                  • 6. Re: problem   sos panic!!!!!!
                    leotemp Level 1
                    You can under the navigator pain right click any file and designate it as the default application, I doubt thats the problem though, can you post your simple application here so i can try it myself?
                    • 7. Re: problem   sos panic!!!!!!
                      safaman Level 1
                      hi leotemp
                      here is an absolutely simple mxml

                      <?xml version="1.0" encoding="utf-8"?>
                      <mx:Application xmlns:mx=" http://www.adobe.com/2006/mxml" layout="absolute" backgroundColor="black" >
                      <mx:Image source="assets/1.jpg"/>

                      </mx:Application>

                      i wish i could attach the file but this is a very simple one just have a jpg in it and can not even see this in run time
                      my email add is safamanishere@yahoo.com
                      if there is a way to attach the whole folder let me know otherwise i have to zip it and emil you to your email if you do not mind
                      thank you very much for your prompt responses
                      • 8. Re: problem   sos panic!!!!!!
                        leotemp Level 1
                        well after a bit of testing all i can say is that the only way i could reproduce what your expeiriencing is when i set the image source to a location that doesn't exist which brings me to a couple questions
                        1) this is probably it, is your images folder in this example named "assets" in your bin folder or the folder of where you are testing this application from. When your building your application your referencing the files from the folder in which your mxml documents and project reside, so if your project was named MyProject and your images where in MyProject/assets then you would be referencing them correctly in your example for development purposes, however.. when you compile your application it goes into the bin folder or MyProject/bin thats where your flash file is and thats where your browser is pointed when it previews your application, you need to either make a spot for previewing on your machine with all of your assets there or copy your assets folder into the bin folder(right click the bin folder and uncheck read only first) There is probably a much more proper way to do this but thats what i do.

                        2) have you tried putting other controls in there like a label or something that will show up no matter what, if you can view a label control but not your image then its definetly and issue with the compiled version being in a different folder then the development files

                        sorry for all the bad grammar and what not but im away from my normal machine

                        • 9. Re: problem   sos panic!!!!!!
                          RuiRosao
                          Hi Safaman,

                          I don't know if you're still having problems. I experienced the same problem as you described and solved it by installing the version of Flashplayer that goes with Flex Builder 2. In my case this is version 9.0.16.0
                          I had Flashplayer 9.0.0.256 installed and that gave the blank screen, while everything was OK in design mode.
                          I upgraded the Flashplayer in my browser with the version in the Flex Builder 2/Player/debug directory.

                          Hope this helps you
                          Rui
                          • 10. Re: problem   sos panic!!!!!!
                            safaman Level 1
                            hi RuiRosao, ntsiii and leotemp
                            thanks for your help. i installed the flashPlayer 9.16 the latest player and it did not solve the problem. i right clicked the (bin,the mxml ) >property>and checked to archive and derived and now i can see the cotrols and the picture when i run it but i stll have a problem . when i change the backgroundColor it shows the change in design but not at run time
                            i guess you can't win them all @!!@$
                            any suggestion ??
                            thanks
                            • 11. Re: problem   sos panic!!!!!!
                              leotemp Level 1
                              Sorry man but i have very similar problems, it seems as soon as i run the compile once from then on i can not update files in my IIS default web application. It doesnt matter if they are even remotley in the same folder as flex builder, this makes no sense and must be something im doing as i dont see anyone else with this problem. Recompile the app, no change, resave external documents, no change. However, if i go in like you said, uncheck archive, uncheck read only, quickly copy and compile and the restart IIS it does change. I moved to another machine the other day and within 20 minutes this started happening there as well but only when flex builder is run, wierd... Since this whole proccess of copying and changing permissions takes a few minutes ive just given up and moved entirely to my server which although the same machine and config as my dev box doesn't have this problem... arrrg!
                              • 12. Re: problem   sos panic!!!!!!
                                sorrycharlie Level 1
                                I ahve had the same problem since this version was released. I installed it on a new laptop and it worked. Something in the machine config outside of FB that is causing the problem. Best of luck.
                                • 13. Re: problem   sos panic!!!!!!
                                  safaman Level 1
                                  thanks everybody for your advises
                                  after what you guys said, i thought to reinstall everything all over again and that is what i have been doing last 8 hours
                                  and now it works. i will have an image copy of the hard drive.
                                  now i can go ahead and do some learning to keep up with you guys (eventhough is very tough :) )
                                  thanks again everybody