2 Replies Latest reply on Oct 18, 2006 11:22 AM by JeffHowe

    length of path

    Remko78
      Hi There,

      I'm using Robohelp HTML 5.02. I want to import word documents, but for some reason the TOC is not correctly converted if I create the project in certain paths. The problem is that I get the correct TOC and the topics are in project-folder; however there is no correct link between de TOC and the topics (in th eTOC you see a red-cross). I can repair that manually via properties

      The word document is at following location (C:\Documents and Settings\PublicRdam\Desktop\TEST\Sources) and I've used this document each time.

      The paths that went well are (here is de xpj-file situated):
      C:\Documents and Settings\PublicRdam\Desktop\TEST\Actuarieel
      and
      C:\Documents and Settings\PublicRdam\Desktop\New Folder\NewProject

      The following paths didn't work:
      C:\Documents and Settings\PublicRdam\Desktop\New Folder\Testjes\dit\NewProject
      C:\Documents and Settings\PublicRdam\Desktop\New Folder\Testjes\Zou dit pad te lang worden
      C:\Documents and Settings\PublicRdam\Desktop\New Folder\Testjes\NewProject
      C:\Documents and Settings\PublicRdam\Desktop\New Folder\Dit is een hele lange naam om te kijken of het aan de lengte ligt of aan de diepte van de locatie
      C:\Documents and Settings\PublicRdam\Desktop\New Folder\Ditiseenhelelangenaamalleendanaanelkaargeschrevenmisschiendatdathetweldoet

      Is this a known problem to anyone of you??
        • 1. Re: length of path
          AuthorAnne Level 1
          Hi Remko78,

          I don't know anything about importing from Word documents, so can't comment on the TOC problems you are experiencing, but there are definitely problems with long paths in hyperlinks to other topics. The hyperlinks work when you view the topic, but don't work from a compiled CHM.

          Try creating a new folder at the top level of your C drive and copy the project into the new folder. If the TOC is OK in the new location, the problem must be caused by the long path names.

          Anne
          • 2. Re: length of path
            JeffHowe
            Anne has it to rights. "C:\project name" is the way to go to avoid the string limit.