6 Replies Latest reply on Sep 17, 2006 11:01 AM by cosu

    strange timeline problem

    cosu Level 1
      Hello!

      I'm running into the following problem:

      I have the main movie. Let's say that in frame 5 of the main timeline I attach a movieClip that has it's own timeline and plays through it's last frame. Main movie stops on frame 10. Clicking menu items current frame on main timeline becomes 10,11 or 12. Now, whenever I change the current frame for the main movie (even if this is never going back to frame 5) the movie clip loaded in frame 5 starts to play from the start, and I don't want that. There's no actionscript that tells it to do so, I never go back to or before frame 5 in main timeline that would cause mc to reload.

      Please, somebody, tell me what's wrong.

      Thanks
        • 1. Re: strange timeline problem
          kglad Adobe Community Professional & MVP
          are you using attachMovie() to attach that movieclip or do you mean that you bring that movieclip to the stage in the authoring environment on frame 5?

          if it's the later, put the movieclip in its own layer so it's not re-instatiated with subsequent keyframes that you may have added later (in the authoring environment).
          • 2. Re: strange timeline problem
            cosu Level 1
            well, that's the problem: it's just drag and drop to frame 5, on it's own layer. everything has it's own layer.
            • 3. Re: strange timeline problem
              cosu Level 1
              link to .fla file

              I've attached a link to my .fla file. Everything seems so right to me. I just don't figure out what's wrong. Clik on "invita un prieten" at the bottom of the page then clik on any other menu than "homepage". You'll notice that the mc on "tell friend" layer starts over, even if the main timeline only moves between frames 79 and 71.

              Thanks for your help.

              quote:

              Originally posted by: kglad
              are you using attachMovie() to attach that movieclip or do you mean that you bring that movieclip to the stage in the authoring environment on frame 5?

              if it's the later, put the movieclip in its own layer so it's not re-instatiated with subsequent keyframes that you may have added later (in the authoring environment).


              • 4. Re: strange timeline problem
                cosu Level 1
                I discovered why is this happening, but have no idea how to fix it.

                So, the layers that containd the triggers (buttons) were masked layers. As soon as I unmasked those layers the problem dissapeared.

                Is this a bug?

                Test it yourself... the files is still on the server...
                • 5. Re: strange timeline problem
                  kglad Adobe Community Professional & MVP
                  i don't see a problem with your linked file. but i also don't see anything that you mentioned in your above message. did you link the wrong file?
                  • 6. Re: strange timeline problem
                    cosu Level 1
                    the error is there. the "invita un prieten" mc shouldn't do anything when changing the page from "homepage" to any other page and viceversa... As I've said, the problem is the masking. As soon as I unmasked the menu layer and the tell friend layer... the problem was gone...

                    quote:

                    Originally posted by: kglad
                    i don't see a problem with your linked file. but i also don't see anything that you mentioned in your above message. did you link the wrong file?