0 Replies Latest reply on Sep 21, 2006 11:35 AM by MikeGwc

    Hints for Redhat FC5 and flash 7,0,68,0 plugin

    MikeGwc
      Here's how to get the Adobe Flash 7,0,68,0 plugin to work with Redhat FC5 with
      either Konqueror, Firefox 1.5.0.7, or Mozilla.

      If the Adobe Flash plugin fails to work at all, or works but shows no text in
      buttons, etc, such as those for the plugin settings, following these steps should
      help.

      There are three elements that may need addressing:

      1) The plugin is looking for the font server configuration file 'config' in
      /usr/X11R6/lib/X11/fs/, when in fact it is now located in /etc/X11/fs/. The
      plugin also scans for fonts on your system located in /usr/share/fonts/ and
      /usr/X11R6/lib/X11/fonts/. /usr/share/fonts/ is fine; the second path isn't.
      These location changes are due to the XFree86 -> Xorg changes made recently,
      which the plugin hasn't been updated to reflect. To get the plugin working
      again:

      a) As 'root', create a directory in /usr/X11R6/lib called 'X11'.
      b) Create a symbolic link to the new location of fonts:
      ln -s /usr/share/X11/fonts /usr/X11R6/lib/X11/fonts
      c) Create a directory called /usr/X11R6/lib/X11/fs
      d) Create a symbolic link to the font server config file:
      ln -s /etc/X11/fs/config /usr/X11R6/lib/X11/fs/config
      e) Make a note for yourself somewhere to remind you to nuke these
      changes when Flash plugin is finally fixed: rm -fr /usr/X11R6/lib/X11

      2) Be careful when making changes to the font server config file. If you
      need to make changes, always use the chkfontpath(8) command. If you edited
      the file directly using a text editor, make sure you don't inadvertently add
      'tab' characters to the 'catalogue' keyword data. I've noticed the Flash plugin
      chokes on 'tab' characters here, and appears to 'hang'. If you use vim(1), you
      can view unprintable characters by setting the "ignorecase" mode:
      :set ic
      If you don't see any '^I' characters, then you're fine. Moral: Always use
      chkfontpath!

      3) SELINUX may be causing you trouble. If the plugin fails to load, even when
      you've placed it in the correct directory, this is probably the cause. Examine
      libflashplayer.so's security context:

      ls -Zl /usr/lib/mozilla/plugins/libflashplayer.so

      It should have the following value: system_u:object_r:textrel_shlib_t. If
      instead, it has user_u:object_r:lib_t, try restoring the context:

      restorecon /usr/lib/mozilla/plugins/libflashplayer.so

      Check with 'ls' to ensure the context has been updated. If it hasn't, your
      file contexts need updating.

      After performing the above three steps, quit all browser windows and restart
      your browser. Flash should be working now.