1 Reply Latest reply on Sep 19, 2006 11:35 AM by poker_chips

    Security question.

    poker_chips
      I need some security help.

      Lets see if I can explain this.

      1.Create a movie clip holder and set its position.
      this.createEmptyMovieClip("Holder", 1);
      setProperty(Holder, _x, _global.mainx)
      setProperty(Holder, _y, _global.mainy)
      2. Attach a mc to it from within flash.
      Holder.attachMovie("mcimage", "mcimage", 1, {_x:0, _y:0});
      3. If the is an image url the attach this to the mc and apply a mask. This works fine with the security.
      if(_global.imageURL <> ""){
      Holder.attachMovie("mask", "mask_mc", 11)
      setProperty(Holder.mask_mc, _x, _global.imagex);
      setProperty(Holder.mask_mc, _y, _global.imagey);
      Holder.mask_mc._visible = false;
      var ImageHolder:MovieClip = Holder.createEmptyMovieClip("ImageHolder", 10);
      mainmcLoader.loadClip(_global.imageURL, ImageHolder);
      setProperty(ImageHolder, _x, _global.imagex);
      setProperty(ImageHolder, _y, _global.imagey);

      4. Clip loader. This works!
      var mainloadListener:Object = new Object();
      mainloadListener.onLoadInit = function(target_mc:MovieClip):Void {
      target_mc._width = _global.imagewh
      target_mc._height = _global.imagewh
      mask_mc._visible = true;
      target_mc.setMask(ChipHolder.mask_mc);
      target_mc._visible = true;
      }
      var mainmcLoader:MovieClipLoader = new MovieClipLoader();
      mainmcLoader.addListener(mainloadListener);

      6. All this works and displays Here comes the problem. When I try and us an expot to jpg routine I get nothing if I have a image loaded from another domain. If the image is from my domain it works fine or if there is no loaded image it works fine. Where or what security issue am I missing or am i missing some other flash issue.

      Should I make a sample app and provide it for debug?