7 Replies Latest reply on Oct 27, 2006 1:09 PM by Just Mary

    Search feature in Firefox is UGLY

    charlene_e
      I have read a few topics discussing an ugly search representation that has, instead of a text entry box, a list of keywords and numbered occurences, similar to an index. This is showing up when my help output is viewed in Firefox 1.5. The search shows up like this when the help is launched from within the application. If I open up the help from where it was installed (opening the actual main .htm file through the browser), the search looks fine. In another application I use WebHelp in, the search looks fine in Firefox, even when launched from within the application.

      Does anyone have this same problem in Firefox in Windows? And, any ideas as to why, the search displays differently depending on how I launch it? Could it depend on how the help window is being called?

      Project is set to generate DHTML > Java Applet > Pure HTML
        • 1. Re: Search feature in Firefox is UGLY
          HKabaker Level 2
          please ignore this post.
          • 2. Re: Search feature in Firefox is UGLY
            RoboWizard Level 4
            Hi charlene_e and welcome to our community

            Hmmm, I'm not sure what's up. I use Firefox version 1.5.0.7 and my Index and Search both work fine and look very similar to IE's version.

            I'm guessing either you aren't using the latest version of Firefox or your machine isn't configured quite like mine. But mine is probably just at Firefox defaults. What version of RoboHelp are you using? I'm on X5.0.2.

            Cheers... Rick
            • 3. Re: Search feature in Firefox is UGLY
              HKabaker Level 2
              In my environment, I can use any of the four main browsers to launch a Web-based application that calls WebHelp.

              The WebHelp Search function behaves fine, and the browser history doesn't get messed up. The nav pane and frame layout differ slightly among the browsers in spacing and borders separating the panes.

              That's with IE, Firefox, Netscape and even Opera.

              I haven't been able to make Opera use the X-hide function and restore the nav pane when you click In oneor two of the browsers the "Go" button it dead, but I can type in a keyword and Enter to make it run.

              It has been a while since I summed up the various ouput patches you need to fine-tune the navigation pane. You might find some old posts in the forum, and maybe on Peter's site at www.grainge.org. Next week I'll try to spend some time on posting an update here.

              Harvey'

              • 4. Re: Search feature in Firefox is UGLY
                charlene_e Level 1
                I am running Firefox 1.5.0.7; it was doing the same thing in 1.5.0.6 yesterday. RoboHelp is X5.0.2.

                I looked through old postings and Peter's site before posting here but haven't found anything that really explains the issue.

                What really doesn't make sense to me is why it works okay sometimes and other times not. I do wonder if it's a Firefox setting somewhere, but I have no idea where the setting would be. Maybe I'll play around a bit with the options.
                • 5. Re: Search feature in Firefox is UGLY
                  Jack DeLand
                  You might try the Firefox forum as well. They're helpful folk.
                  • 6. Re: Search feature in Firefox is UGLY
                    HKabaker Level 2
                    Yesterday I posted a new topic on this subject,

                    "Frame loading, TOC, Index, Search display problems in Firefox, et al. "

                    (just in case readers of this topic don't make the connection from the topic list)

                    Harvey
                    • 7. Re: Search feature in Firefox is UGLY
                      Just Mary Level 1
                      Charlene,

                      Check your JavaScript option in Firefox; it needs to be enabled to show to show full help functionality, including the Search pane. (This is true for your users, too.)

                      1. Select Tools > Options.
                      2. Click Content.
                      3. Make sure Enable JavaScript is selected.

                      Hope this helps.

                      Mary