10 Replies Latest reply on Oct 23, 2006 2:26 PM by Lorin_G

    Problem on export (Flash MX)

    Lorin_G
      When I export from flash MX, the progress meter stops about halfway and stays there for a while, then is gone. I have figured out that it is only exporting a small part of the swf. The swf file sizes are just a fraction of what they should be and do not play back properly online, they just leave a blank page.

      This is a recent occurrence, I've been using this copy of Flash MX on this machine for 2 years and this is the first it has happened.
      -plz advise

      running mac, dual G5, OSX 10.4.8 with 4.5GB RAM
        • 1. Re: Problem on export (Flash MX)
          Lorin_G Level 1
          I tried reinstalling Flash but still no luck....
          ...somebody......anybody???
          • 2. Re: Problem on export (Flash MX)
            Level 7
            it's probably something in the document - but hard to pinpoint the issue without knowing what your
            movie contains.

            ******************************************
            --> **Adobe Certified Expert**
            --> www.mudbubble.com
            --> www.keyframer.com




            Lorin G wrote:
            > I tried reinstalling Flash but still no luck....
            > ...somebody......anybody???
            • 3. Re: Problem on export (Flash MX)
              Lorin_G Level 1
              This is happening with multiple documents. Now I'm even having problems saving the .fla files.

              I had saved and exported these files without any problems a week ago. Now nothing but problems.

              The first file I noticed the issue with was a music player with a preloader that is called into the main movie.

              I'm scared to open these files on a different computer because I don't want them to cause problems on other machines. I've tried copying and pasting into a new document but when I saved the program froze.

              what the dealio?
              • 4. Re: Problem on export (Flash MX)
                Level 7
                Hard to tell - really havent heard of such a thing unless your machine has a virus of some kind -
                make back-ups now - run anti-virus and all that security stuff - then report back - try sending me a
                file if you want.

                ******************************************
                --> **Adobe Certified Expert**
                --> www.mudbubble.com
                --> www.keyframer.com




                Lorin G wrote:
                > This is happening with multiple documents. Now I'm even having problems saving
                > the .fla files.
                >
                > I had saved and exported these files without any problems a week ago. Now
                > nothing but problems.
                >
                > The first file I noticed the issue with was a music player with a preloader
                > that is called into the main movie.
                >
                > I'm scared to open these files on a different computer because I don't want
                > them to cause problems on other machines. I've tried copying and pasting into a
                > new document but when I saved the program froze.
                >
                > what the dealio?
                >
                • 5. Re: Problem on export (Flash MX)
                  Lorin_G Level 1
                  I'm running on a mac, not sure about virus but maybe. I ran the disc utility stuff.

                  I also have to re-open all the tools and palettes again every time I launch the flash program.

                  this is wacky.
                  • 6. Re: Problem on export (Flash MX)
                    Lorin_G Level 1
                    More info:
                    There seems to be a problem with the fla file itself. If I "get info" on the fla file it reads 19.3MB which seems absolutely ludicrous considering the only things in the file are:
                    -1 small png image.
                    -some looping vector graphics built in flash.

                    This flash file should be under 500k, probably even under 300k. I went through the library and deleted everything that was unnecessary. I think something in the file is causing it to be so large, but I can't figure out what it is. I've tried saving copies, tried copying an pasting...damn this is bizarre.

                    can anyone help me?
                    • 7. Re: Problem on export (Flash MX)
                      Level 7
                      Do a save as with new name.

                      ******************************************
                      --> **Adobe Certified Expert**
                      --> www.mudbubble.com
                      --> www.keyframer.com




                      Lorin G wrote:
                      > More info:
                      > There seems to be a problem with the fla file itself. If I "get info" on the
                      > fla file it reads 19.3MB which seems absolutely ludicrous considering the only
                      > things in the file are:
                      > -1 small png image.
                      > -some looping vector graphics built in flash.
                      >
                      > This flash file should be under 500k, probably even under 300k. I went through
                      > the library and deleted everything that was unnecessary. I think something in
                      > the file is causing it to be so large, but I can't figure out what it is. I've
                      > tried saving copies, tried copying an pasting...damn this is bizarre.
                      >
                      > can anyone help me?
                      >
                      • 8. Re: Problem on export (Flash MX)
                        Lorin_G Level 1
                        tried that many times.
                        I think I have cornered the issue:
                        It has something to do with an audio file I've imported. I recreated a new file cutting and pasting into frames, small parts at a time and it kept the file at 80k, where it should be.

                        However, when I import the mp3 (which is 2.2MB) for some reason the flash file becomes a 19MB file. Even when I delete the file from the library it still remains a 19MB file...weird.

                        Maybe I'm not importing the right type of audio file or something. It was a download from a podcast. Is there a certain way I should export the audio from iTunes to get optimum quality and avoid the issue?
                        • 9. Re: Problem on export (Flash MX)
                          Lorin_G Level 1
                          I've tried importing other MP3's just to see if it has something to do with that particular audio file, but it does the same thing with all audio files....and it sounds like crap on the swf replay.

                          maybe I'm importing the audio improperly, but it's the same way I've done it for years and never had any problems.
                          • 10. Re: Problem on export (Flash MX)
                            Lorin_G Level 1
                            got a little more info.
                            It appears that flash is not exporting the entire file for some reason. It starts to exports and sits there idle for a while, then just finishes. The swf then plays as a preview but if I put it online and hit the url nothing happens, just a blank white page. When I look at the file sizes they are far too small, say the swf should be around 2-3MB, it exports at around 300-400k.

                            I've also tried installing flash mx on another machine to test it, but I'm having the same problems. I think there is some kind of ghost messing with my stuff.

                            It seems as though any time I have an issue it's unsolvable.