5 Replies Latest reply on Sep 25, 2006 4:16 PM by Newsgroup_User

    Shockwave PHP5 Mac OSX problem?

    melodank
      Hi, I'm curious if this has been documented or if anyone knows about this potential problem.
      I've used postnettext with php4/mysql in my shockwave movie. Has always worked great on both pc and mac.
      I recently switched to php5 from php4 and while the connections work fine in Director, in Shockwave on Mac OSX the connection will not return any information. It works fine on PC.

      Any thoughts or information on this would be greatly appreciated! Thanks.
      : )
        • 1. Re: Shockwave PHP5 Mac OSX problem?
          melodank Level 1
          I think this is actually an issue between mysql 4 and 5. Anyone?
          • 2. Re: Shockwave PHP5 Mac OSX problem?
            Level 7
            Hi,

            Did you try the requests in a browser?

            I'm no php expert, but the thing I've seen going wrong most often on new
            php installs is issues with the 'register_globals' directive.

            On earlier installs (I think it was 4) all parameters on the request or
            from the form were automatically converted to variables in PHP. Like with:

            www.test.com/index.php?foo=bar

            in the php file there would be a variable 'foo' with the value 'bar'.
            In current versions due to security (and performance) issues you have to
            explicitly convert them to variables. Like:

            $foo = $_GET["foo"];

            Just might be it...
            Manno


            melodank wrote:
            > I think this is actually an issue between mysql 4 and 5. Anyone?

            --
            ----------
            Manno Bult
            manno@xs4all.nl
            • 3. Re: Shockwave PHP5 Mac OSX problem?
              Level 7
              Oops

              will read better before I answer
              will read better before I answer
              will read better before I answer
              will read better before I answer
              ...

              Only while playing back on OSX? What's the setup?

              Manno Bult wrote:
              > Hi,
              >
              > Did you try the requests in a browser?
              >
              > I'm no php expert, but the thing I've seen going wrong most often on new
              > php installs is issues with the 'register_globals' directive.
              >
              > On earlier installs (I think it was 4) all parameters on the request or
              > from the form were automatically converted to variables in PHP. Like with:
              >
              > www.test.com/index.php?foo=bar
              >
              > in the php file there would be a variable 'foo' with the value 'bar'.
              > In current versions due to security (and performance) issues you have to
              > explicitly convert them to variables. Like:
              >
              > $foo = $_GET["foo"];
              >
              > Just might be it...
              > Manno
              >
              >
              > melodank wrote:
              >> I think this is actually an issue between mysql 4 and 5. Anyone?
              >

              --
              ----------
              Manno Bult
              manno@xs4all.nl
              • 4. Re: Shockwave PHP5 Mac OSX problem?
                melodank Level 1
                Yep, this is an issue in Shockwave on Mac OSX only. My Mac is NOT a newer Intel based one, btw. I'm curious if that as an impact.

                So the postnettext to php is sending fine to the mysql 5, but not returning anything. Works fine on mysql 4. Works fine on pc.

                I suppose I should report this to adobe for the next shockwave update? Any idea how to do that?
                • 5. Re: Shockwave PHP5 Mac OSX problem?
                  Level 7
                  On Mon, 25 Sep 2006 21:13:28 GMT, melodank posted in
                  macromedia.director.lingo:

                  > Yep, this is an issue in Shockwave on Mac OSX only. My Mac is NOT a
                  > newer Intel based one, btw. I'm curious if that as an impact.
                  >
                  > So the postnettext to php is sending fine to the mysql 5, but not
                  > returning
                  > anything. Works fine on mysql 4. Works fine on pc.
                  >
                  > I suppose I should report this to adobe for the next shockwave update?
                  > Any
                  > idea how to do that?

                  That is odd.

                  One thing that might help troubleshoot is seeing if the information
                  sent and received is consistent. You can use something like Ethereal to watch
                  the network traffic.

                  I think they have a downloadable Mac binary available.

                  http://www.ethereal.com/


                  --
                  Mark A. Boyd
                  Keep-On-Learnin' :)