2 Replies Latest reply on Aug 13, 2007 5:06 PM by (Craig_Lomas)

    Error creating temporary table

      I've created a simple Insert Record form using the wizard and uploaded all the includes files. I receive the below error when loading the page:

      I've checked the other threads in this forum and none of them seem to sole this problem... I've checked for the use of reserved words but I do not seem to have used any.

      Thanks

      --------------------------------------------------------------------

      Error:
      Internal error.
      Developer Details:
      tNG_fields.getFakeRecordset:
      SQL error: Error creating temporary table:
      You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'show TEXT, reviewDate TEXT, reviewerNamePub TEXT, starRating TEXT, reviewText TE' at line 1
      SQL:
      CREATE TEMPORARY TABLE KT_fakeRS_20070814 (show TEXT, reviewDate TEXT, reviewerNamePub TEXT, starRating TEXT, reviewText TEXT, reviewLink TEXT, reviewID TEXT) (FIELDS_FAKE_RS_ERROR)
      tNG Execution Trace - VIEW

      * tNG_insert.executeTransaction
      o STARTER.Trigger_Default_Starter
      * tNG_insert.getRecordset
      * tNG_insert.getLocalRecordset
      * tNG_insert.getFakeRecordset*

      --------------------------------------------------------
        • 1. Re: Error creating temporary table
          Günter Schenk Level 4
          Hi Craig,

          >>
          I've checked for the use of reserved words but I do not seem to have used any.
          >>

          Gotcha ! :-) You can´t use the term "show" as MySQL column name, because it´s indeed a "reserved word" -- please rename the field to something else, and make sure to avoid the reserved words indicated on this page:

          http://www.htmlite.com/mysql002a.php

          Günter Schenk
          Adobe Community Expert, Dreamweaver
          • 2. Re: Error creating temporary table
            Level 1
            Hi Gunter,

            Cheers for the reply... I did look at a list of reserved words and couldn't see it there... but I've changed it and it worked so obviously I missed it!... thanks for pointing it out to me... thought it would be a simple solution :)

            Cheers again :0)

            Craig