7 Replies Latest reply on May 11, 2009 8:06 AM by Clive

    File Upload Large file

    Clive
      When uploading files from a digital camera resizing to 400 x 300 I get either a file size error 8388608 or internal server error.

      After reading other similar problems I've created a php.ini file as follows:

      memory_limit=64M
      upload_max_filesize = 64M
      Still getting the same errors.

      Can anyone suggest anything else I should be doing to try and get round the problem?
      Asking my client to resize images before loading will not go down too well..

      Thanks in advance
      Clive
        • 1. Re: File Upload Large file
          Günter Schenk Level 4
          Hi Clive,

          there are other php.ini settings which you also might want to modify, like:

          - "set_time_limit": http://de.php.net/set_time_limit

          - "max_execution_time": http://de.php.net/manual/en/info.configuration.php#ini.max-execution-time

          Cheers,
          Günter Schenk
          Adobe Community Expert, Dreamweaver
          • 2. Re: File Upload Large file
            Clive Level 1
            Hi Günter
            Many thanks (yet again!) for trying to help me out.

            Unfortunately neither parameter overcame the problem but thanks for the advice anyway it is much appreciated.

            Regards
            Clive
            • 3. Re: File Upload Large file
              Günter Schenk Level 4
              Hi Clive,

              as you said you´re "created" a php.ini file...is this really supported by your host ? I´m just asking because most shared hostings out there don´t allow this and usually ignore such a file, whereas placing such directives within an .htaccess file is usually possible.

              Cheers,
              Günter Schenk
              Adobe Community Expert, Dreamweaver
              • 4. Re: File Upload Large file
                921creative Level 1
                I personally had success by placing an .htaccess file at the root of my web docs with the following:

                php_value upload_max_filesize 30M
                php_value post_max_size 30M
                php_value max_execution_time 300
                php_value max_input_time 300
                • 5. Re: File Upload Large file
                  asdaf1234

                  I Can't overcome host php settings with .htaccess file as above 921creative has done...

                   

                  my php limit is

                   

                  24mb

                  max_execution_time 45

                  max_input_time 60

                   

                  But I need more time for upload videos... Is there any other way to do that?

                  Time is the basic problem...

                   

                  With filezilla I can upload as big video as I want, but how I put that path info to the database... OK by writing it to the correct field...Any other ideas for other users who do not use/can't access dir by filezilla?

                  • 6. Re: File Upload Large file
                    coltrane42

                    Clive,

                     

                    I was running into similiar issues uploading and resizing image files just today (even though I wasn't actually getting any errors reported)...

                     

                    I had tested images that were higher file sizes and everything seemed to work fine, but when a user tried to upload an image with really large dimensions (over 2-3k pixels wide), the application just didn't perform the resize at all (even though the overall file size was actually smaller than others I had successfully tested).  This created a few problems, because the file got uploaded in its original size, and whenever someone viewed the page and my application tried to create a thumbnail, it just crashed the page!

                     

                    I found something that seemed to help me, and hopefully it will be interesting to your case as well.  The answer seemed to be in adjusting the "memory_limit" parameter of my php.ini file to something much larger than I had before... (probably too large, but I it's a temporary fix at least)

                     

                    post_max_size = 20M
                    upload_max_filesize = 10M
                    memory_limit = 160M
                    max_execution_time = 120

                     

                    (*I think you can also make this change via the .htaccess file as others have suggested, depending on your hosting configuration)

                     

                     

                    You can read more about the particular resource demands of various image uploads in the article I mentioned by following the link below:

                    http://www.linuxquestions.org/questions/linux-newbie-8/php.ini-uploadmaxfilesize-2meg-erro r-on-large-pixel-images-under-1meg-713915/?s=978287162c0b0050b42fed36522965df

                     

                    Anyways, that might not help... but who knows!

                     

                    Good luck

                    • 7. Re: File Upload Large file
                      Clive Level 1

                      Hi

                      Just in case anyone else has the same problem...

                      I finallygot round my problem with the help of my hosting provider.

                       

                      I had to saet up a htaccess file with the following line

                       

                      RLimitMem 128000000

                       

                      Kind regards

                      Clive