3 Replies Latest reply on Nov 28, 2007 2:08 PM by (Charles_Briere)

    Problems with Dynamic Lists & Forms after adding another field

      Hi:

      CS3, ADDT, XP, MySQL, PHP.

      We created a "cases" list with the ADDT button Create Dynamic List Wizard, then created the corresponding form with Create a Dynamic Form Wizard. Saved and uploaded. Entered data and play with it and everything was working just perfect.

      However, we need to add another menu field ("defendants") to the "cases" list/form. So, we added another table called defendants_def to our MySQL database that contains two fields, id_def and desc_def, and inserted two testing records on it.

      Then we went to the "cases" list and clicked on Manage Dynamic List Wizard to add this new menu field. Added the field, set it as menu and clicked finish.

      We did the same in the "cases" form, clicking Manage Dynamic Form Wizard to add this new menu field. Added the field, set is as menu and clicked on finish.

      We had to create a Recordset for the "defendants" table.

      Then, we save all pages, uploaded, and every column/field is displayed in the list including "defendants" but no data is displayed. We then clicked update that took us to the corresponding form, choose a value for defendants clicked updated and no data as to defendants field is displayed on the list.

      Since it was not working as expected, we also reuploaded the includes folder, but it still don´t work.

      The thing is that every time you tried to add another field to a list/form ADDT does not processes it as expected.

      The solution: create the WHOLE form again from scratch!!!

      I think the problem is in the MANAGE Dynamic List/Form Wizard.

      Please help to solve this issue, because creating the whole list/form pages AGAIN is not what ADDT was made for.

      Then, after all this, we now have another issue.

      There are no recordsets on the pages.
      This is the error message when we open the list and click on Manage Dynamic List Wizard:
      "NoListRecordSet found on the page". Yes, and there are no records on the Applications Panel/Servers Behaviours. All gone!

      Any clues?

      Thanks,

      Charles
        • 1. Re: Problems with Dynamic Lists & Forms after adding another field
          Günter Schenk Level 4
          Hi Charles,

          ------
          Any clues?
          ------

          not really, because what you´re describing, could happen for various reasons, and without seeing any code it´s impossible to provide help anyway.

          However your issues could be related to ADDT´s database caching, which is enabled by default and can be a good thing, because it "remembers" previously defined table & form settings by storing/retrieving information regarding the table names, table primary keys and field types in/from a local cache rather than making another call to the database server -- but at the same time this cached information can come in your way after adding new tables or form fields, so I can only recommend to clear the cache by...

          1. opening the Control Panel

          2. clicking the "User interface persistance and database caching" button at the bottom,

          3. clicking the "empty Cache" button

          Does this help ?

          Cheers
          Günter Schenk
          Adobe Community Expert, Dreamweaver
          • 2. Re: Problems with Dynamic Lists & Forms after adding another field
            Level 1
            Well,

            That solved part of the problem.

            Now, we can see in the list the "value" of the field instead of its "label".

            However, I checked the list/menu and it is ok.

            Also checked the recordsets and includes the two fields and if I press the "test" button it displays the correct labels and values.

            Any clues?

            Thanks,

            Charles

            PD. I have already invested several hours trying to troubleshot the problem. Now I am SURE that redoing the pages AGAIN is a better strategy, and less time consuming!
            • 3. Re: Problems with Dynamic Lists & Forms after adding another field
              Level 1
              We have created the list and form AGAIN and had no problems. Certainly was not the most time-conscious strategy, but solved the problem.

              But, does anyone out there had the same problem as we do?

              Maybe our version have a bug or we are doing the procedure in an incorrect way.

              Do a pre-established procedure exists to add fields using the wizards AFTER creating the lists/forms? There must be trick. I think this issue also happened when we had 3.7.1.

              Thanks,
              Charles