11 Replies Latest reply on Jul 2, 2008 5:02 AM by benblue

    ADDT QuB isnt working for me

      Hi folks,

      I was doing the Discussion Board tutorial and got stuck at the part where i have to use the Query Builder to make a query.

      So i add a record set, make the basic selections and press the QuB button, i make the next basic selections and pres 'New Query'.. so far so good.

      The Query Builder interface loads and in the middle of the screen i see the message 'Please wait while loading...' and thats it. No tables are loaded, this is a screenshot: http://www.wicservices.nl/zbrush/builder.jpg

      I did some serious efforts to find the problem in this and other forums but cant seem to find the solution for me, i tried turning off firewall and anti virus, i updated all files in the include folder, tried it in FF and IE, tried it with a database with only two tables (my original attempt had 70 tables or something). Someone talked about system memory problems, but i think 1 Gb could be quite enough without other heavy apps running. I also tried it on different PC's on different locations, ehm i know i have access to the database and all.

      so i don't know :) anyone has a suggestion?

      oh, and i'm not experienced enough to make the query myself ^^ that would be the next step huh. This is the page in the tutorial, maybe someone feels like helping me out ^^ http://www.interaktonline.com/Documentation/MXKollection/#000000_Intro.htm

      look for:
      - tutorials
      - Discussion board
      - Post and list messages
      - Display message threads (first actions on this page)

      thanks in advance for any comments,
      symvar
        • 1. Re: ADDT QuB isnt working for me
          Günter Schenk Level 4
          Hi symvar,

          how many records do your 2 tables currently have ? I´ve heard of similar cases where folks tried to load tables with, say, 1000 records or so, what actually made the browser freeze.

          Cheers,
          Günter Schenk
          Adobe Community Expert, Dreamweaver
          • 2. Re: ADDT QuB isnt working for me
            Level 1
            ehm, the database i tried to use at first has 78 tables with 2648 records but the other database has just 2 tables with 41 records.
            • 3. Re: ADDT QuB isnt working for me
              Level 1
              anyone has experience with this maybe? :)

              symvar
              • 4. Re: ADDT QuB isnt working for me
                Hi,

                The problem I'm getting with qub, is that when I click the create recordset icon, and the window appears - the connection name will appear but the tables do not show in the drop down menu, so that I can select a table to work with?

                Any thoughts anyone?

                I'm using zonealarm with dreamweaver given super permissions.

                Thanks, Mark
                • 5. Re: ADDT QuB isnt working for me
                  Günter Schenk Level 4
                  Hi Mark,

                  can you temporarily deactivate Zonealarm (or even shut it down) and see if it´s better now ?

                  Cheers,
                  Günter Schenk
                  Adobe Community Expert, Dreamweaver
                  • 6. Re: ADDT QuB isnt working for me
                    Level 1
                    @ Mark:
                    does the mysql connection work when you use it for a simple query
                    and dont use QuB?
                    • 7. Re: ADDT QuB isnt working for me
                      glensbo Level 1
                      Symvar

                      I had a problem recently with Qub - it turned out to be Firebug that caused the problem for me. I disabled Firebug and haven't had any problems since (so far)

                      Regards
                      • 8. Re: ADDT QuB isnt working for me
                        Level 1
                        Hi Henrik,

                        I tried this but it didnt work for me, however i started looking for a solution again and found my problem!!! Thanks for your reply ghehe.

                        For some reason (dont ask me why) when i set up a site in dreamweaver and the password contains a % symbol i have to place the number 25 behind it. For example a password 123%456 would become 123%25456.

                        This password with the %25 works only local, on the remote site the mysql connection file needs the password without the %25. I guess this is only with my current webhost or something but because we always use this webhost i'm completely used to work with this 'workaround'.

                        So i now tried to make a new recordset with QuB and just before i press 'New query' and enter a name i change the password in my local mysql connection file to a password without the extra '25'. and the QuB screen loads!!

                        It seems a logical solution now, but lol.. I think i'm quite lucky i actually found it...

                        @ Günter; maybe u can help someone with this problem ;p

                        greets,
                        symvar
                        • 9. Re: ADDT QuB isnt working for me
                          I encountered this situation on a password with special characters as well. Not sure if it was the semi-colon or dollar-sign that caused the problem, but when I changed to a less secure but kinder password, QUB stopped hanging and loaded the data.

                          Thanks Symvar for the insight!

                          I hope that someone will succeed in correcting this so we can work with a more secure password in place.

                          -shoshanaz
                          • 10. Re: ADDT QuB isnt working for me
                            benblue
                            hello all -

                            glad some have solved this in their issue. this just happened to me, first time ever, been using QuB for a while.

                            It loads, and then the list of tables is just empty.
                            If i go back to SIMPLE RECORDSET window, i CAN see all my tables.
                            AND i tried it for a different site, one i had used previously, with QuB, and it DID work there.

                            I recently acquired the WebAssist SuperSuite (any other comments about that...new thread :) ) and think one of the extensions has created a conflict.

                            When i get home i will try to isolate which one, and hopefully remember to let all you know the results in case it helps.

                            im thinking its a file somewhere inside (PC)User/Documents and Settings/Application Data/Adobe/Configuration/Shared...

                            but not sure. ill let you know, as well as try disabling firebug, (even though ive had firebug and been using QuB. I think. :) )

                            cheers,
                            ben
                            • 11. Re: ADDT QuB isnt working for me
                              benblue Level 1
                              solved my version of this issue.

                              I had an "&" in a table name. changed it and, fixed!

                              rookie mistake. so any of u may want to check for any special characters in db or table names...

                              best,
                              ben