2 Replies Latest reply on Mar 4, 2008 9:17 PM by mrcharis2003@yahoo.c

    using addt show thumbnail with dw master page set

    mrcharis2003@yahoo.c Level 1
      Hi there

      I am using dw master page set with the addt show thumnail behavior
      and is working really well the tables show the correct thumb for the data in the cell all is working great....... but........

      In the master detail page set wizard there is a drop down menu/field to choose which item in the detail table to link to the master detail table

      After I complete the wizard I then add a new cell and add the adt show thumb behavior to that empty cell and it all works great .... but......

      I want to link from the thumb to the master detail page (the same as nearly every site on the web)
      I thought i had i figured out I just highlight the thumb , go to the property inspector and a link to the detail page and it works...... no
      So it does work, it links to the master detail page no problem but all the fields in the master detail page are now empty if I go back and click on another link to the master detail page it shows all the correct info, all the fields are full ........

      So........... is there any way to link from the detail page to the master detail page using the addt show thumb behavior?
      Is there a way to populate the dropdown menu in the master detail page set wizard so that I can choose the thumb created by addt to link from?

      Any help would be great......
      have a nice day
        • 1. Re: using addt show thumbnail with dw master page set
          Hi Charis,<br />You can create the link from the thumbnail to the detail page by linking the <br />image to the detail page in the normal way but before closing the  link <br />dialogue box down select 'parameters'.<br />In the two fields there fill in the primary key for the recordset in the <br />left column and then select the primary key from the recordset dropdown in <br />the right.<br />When you then click the link it will send the correcy id to the detail page.<br /><charis@adobeforums.com> wrote in message <br />news:3c064a1c.-1@webcrossing.la2eafNXanI...<br />> Hi there<br />><br />> I am using dw master page set with the addt show thumnail behavior<br />> and is working really well the tables show the correct thumb for the data <br />> in the cell all is working great....... but........<br />><br />> In the master detail page set wizard there is a drop down menu/field to <br />> choose which item in the detail table to link to the master detail table<br />><br />> After I complete the wizard I then add a new cell and add the adt show <br />> thumb behavior to that empty cell and it all works great .... but......<br />><br />> I want to link from the thumb to the master detail page (the same as <br />> nearly every site on the web)<br />> I thought i had i figured out I just highlight the thumb , go to the <br />> property inspector and a link to the detail page and it works...... no<br />> So it does work, it links to the master detail page no problem but all the <br />> fields in the master detail page are now empty if I go back and click on <br />> another link to the master detail page it shows all the correct info, all <br />> the fields are full ........<br />><br />> So........... is there any way to link from the detail page to the master <br />> detail page using the addt show thumb behavior?<br />> Is there a way to populate the dropdown menu in the master detail page set <br />> wizard so that I can choose the thumb created by addt to link from?<br />><br />> Any help would be great......<br />> have a nice day
          • 2. Re: using addt show thumbnail with dw master page set
            mrcharis2003@yahoo.c Level 1
            Hi thanks for your reply

            I have been trying to get this working for ages

            I will explain again for anyone new to this thread

            I want to link from a thumbnail ( generated by addt show thumbnail behavior) to the detail page using the 'master detail page set'
            My problem is that when I create the link from the thumbnail it links to the detail page no problem but the detail page contains no info

            Basically I am creating a site with business info and I want a basic list page with only a thumb name of business and date added and then I want to link to a more detailed page with more information

            Now I know that the master detail page set is working because I have got it all working fine I have set one of the fields in the list page table (the business name field) to be the link to the detail page(as set up in the wizard) and it all works good. All the basic info is displayed in the list page and when I click on the name it links to the detail page which has more detailed info (about the corresponding business from the list page)

            Oh and I should say that I have set up my upload form with file fields to upload pics and that all works no problem too I can display thumbs on my list page and show images on my detail page no problems
            So......
            I have been following what you said and I am still not getting the correct info displayed on my detail page, the detail page that I am trying to link from the thumb (the link from the 'business name' field works fine) ( my detail page contains no info or pics only blank fields, when linked from the thumb )

            So I will explain the steps I am taking

            after I have completed the master detail page set wizard I have the two pages I want, the master list page and the detail page and the link from the business name field works fine.... so far so good

            I use the 'show thumbnail' addt server behavior to insert a thumb into one of the cells I then preview and the thumb shows up ... no problem
            So then I go back into DW and highlight the thumb image and go to the property inspector and open the link dialogue box and then choose the detail page to link to
            I then click on the parameters button and write the primary field for the table that the recordset uses,which is 'bus_id' (into/under the 'name' field) then I choose the same 'id_bus' from the lightning bolt drop down menu (into/ under the 'value' field)

            then I test it and again the thumb links to the detail page but the detail page is still empty
            So I go back and do it all again and get the same results
            then I test the link from the 'bus name' field and it still works fine

            So........ am I doing something wrong
            I have tried hard to figure this out for myself but I still cannot get it working
            Any ideas?

            Any help would be great as this is one of the most important features to all the sites I am working on

            Thanks again for all you help
            hope I can get it working soon

            Have a nice day