1 Reply Latest reply on Aug 21, 2008 4:45 AM by Günter Schenk

    Dependent Drop-downs and comma separated checkboxes not working in IE?

      Hi ll,

      This is probably something really simple that I'm missing. I've got a fairly involved page with a dependent drop down set in one section of the page and about 30 comma separated checkbox sets, all of which great in Safari and Firefox but don't work in any version of IE. I hate IE!!!!!

      The drop downs are fairly simple and work well in the other browsers. The check boxes are pulling data from an attendees table. It's not the data because it all works in FF and Safari!

      Anyway, I am assuming this may have something to do with the errors reported when validating the page with DWCS3. They all have something to do with the widget. listed just a below but every line with an ADDT widget in it has an error. The strange thing is that I have the same widget (comma separated check boxes) on other pages and they work fine in IE!

      Any help much appreciated and thanks in advance!

      Sample validation errors:

      The tag: "html" doesn't have an attribute: "xmlns:wdg" in currently active versions. 1652
      The tag: "select" doesn't have an attribute: "wdg:subtype" in currently active versions. 2134
      The tag: "select" doesn't have an attribute: "wdg:type" in currently active versions. 2134
      The tag: "select" doesn't have an attribute: "wdg:recordset" in currently active versions. 2134
      etc.... over 164...
        • 1. Re: Dependent Drop-downs and comma separated checkboxes not working in IE?
          Günter Schenk Level 4
          Hi Tony,

          I for once did never have any problems with running the dependant dropdowns or the comma separated checkboxes in IE -- could it be some browser settings which prevent the execution ?

          -------
          Anyway, I am assuming this may have something to do with the errors reported when validating the page with DWCS3
          -------

          DW´s page validation routines try hard to comply with the W3C standards and don´t have any clue about the specific ADDT markup that gets added to certain tags, and proprietary attributes such as "xmlns:wdg" or "wdg:recordset" are probably even sort of invalid, at least according to the W3C specifications -- who knows, but I´m personally not concerned about that, as probably most ADDT lists and forms are not integrated into "public" pages.

          However, the fact that it´s not working "in any version of IE" is pretty weird and is IMO rather related to some browser-specific settings, but apart from this assumption I have no clue what else could cause this.

          Cheers,
          Günter Schenk
          Adobe Community Expert, Dreamweaver