1 Reply Latest reply on Dec 11, 2008 7:57 AM by Waleed Barakat

    Bug - Redirect after update record SB

      I'm having trouble with the redirect function included in ADDT for sending the user to a new page after submitting an update or some other trigger. Some of my pages work, some don't. The code all looks OK, though.

      The page this code is on redirects to a blank page:

      // Register triggers
      $forgotpass_transaction->registerTrigger("STARTER", "Trigger_Default_Starter", 1, "POST", "KT_Update1");
      $forgotpass_transaction->registerTrigger("BEFORE", "Trigger_Default_FormValidation", 10, $formValidation);
      $forgotpass_transaction->registerTrigger("BEFORE", "Trigger_ForgotPasswordCheckEmail", 20);
      $forgotpass_transaction->registerTrigger("AFTER", "Trigger_ForgotPassword_Email", 1);
      $forgotpass_transaction->registerTrigger("END", "Trigger_Default_Redirect", 99, "forgot_password.php");

      The page this code is on works properly:

      // Register triggers
      $upd_users->registerTrigger("STARTER", "Trigger_Default_Starter", 1, "POST", "KT_Update1");
      $upd_users->registerTrigger("BEFORE", "Trigger_Default_FormValidation", 10, $formValidation);
      $upd_users->registerTrigger("END", "Trigger_Default_Redirect", 99, "thanks.php");
      $upd_users->registerConditionalTrigger("{POST.pwd} != {POST.re_pwd}", "BEFORE", "Trigger_CheckPasswords", 50);
      $upd_users->registerTrigger("BEFORE", "Trigger_CheckOldPassword", 60);

      Not sure what's happening.