4 Replies Latest reply on Jan 26, 2009 7:17 PM by Newsgroup_User

    Flash movie not displayed after swfload

    flyingfishnm
      Hi All,

      I have a simple web page that will display photos using a third party flash movie/swf file. The problem is when the page is displayed the third party swf file does not display. Im using the swfloader tag. Any help much appreceiated!
      Thanks
      Davej
        • 1. Flash movie not displayed after swfload
          CMSTorres Level 1
          Did you check if you have the 2dzoomgallery.swf in that folder? 'Cause I've tried changing that path to a local folder and it worked for me.

          Edit: I've also tried loading an swf from my website and it worked fine.
          • 2. Re: Flash movie not displayed after swfload
            flyingfishnm Level 1
            Hi cmstreg,

            Thanks for your reply!

            I have checked and the folder and path do exist. What is strange is if I export the app and upload to the server it works. If I try to run it from my dev machine I get the following error and it doesn't run:

            TypeError: Error #1009: Cannot access a property or method of a null object reference.
            at 2DZoomGallery_fla::menuHolder_2/frame1()[2DZoomGallery_fla.menuHolder_2::frame1:3]

            I also get this error if the app is running from the server and I refresh the browser. I'm new to Flex/Actionscript so forgive my lack of knowledge, but what does this mean??
            Thanks

            Davej
            • 3. Re: Flash movie not displayed after swfload
              Level 7

              "flyingfishnm" <webforumsuser@macromedia.com> wrote in message
              news:gllpab$m7r$1@forums.macromedia.com...
              > Hi cmstreg,
              >
              > Thanks for your reply!
              >
              > I have checked and the folder and path do exist. What is strange is if I
              > export the app and upload to the server it works. If I try to run it from
              > my
              > dev machine I get the following error and it doesn't run:
              >
              > TypeError: Error #1009: Cannot access a property or method of a null
              > object
              > reference.
              > at
              > 2DZoomGallery_fla::menuHolder_2/frame1()[2DZoomGallery_fla.menuHolder_2::frame1:
              > 3]
              >
              > I also get this error if the app is running from the server and I refresh
              > the
              > browser. I'm new to Flex/Actionscript so forgive my lack of knowledge, but
              > what
              > does this mean??
              > Thanks

              http://flexdiary.blogspot.com/2008/09/extended-datagrid-with-stylefunction.html


              • 4. Re: Flash movie not displayed after swfload
                Level 7

                "flyingfishnm" <webforumsuser@macromedia.com> wrote in message
                news:gllpab$m7r$1@forums.macromedia.com...
                > Hi cmstreg,
                >
                > Thanks for your reply!
                >
                > I have checked and the folder and path do exist. What is strange is if I
                > export the app and upload to the server it works. If I try to run it from
                > my
                > dev machine I get the following error and it doesn't run:
                >
                > TypeError: Error #1009: Cannot access a property or method of a null
                > object
                > reference.
                > at
                > 2DZoomGallery_fla::menuHolder_2/frame1()[2DZoomGallery_fla.menuHolder_2::frame1:
                > 3]
                >
                > I also get this error if the app is running from the server and I refresh
                > the
                > browser. I'm new to Flex/Actionscript so forgive my lack of knowledge, but
                > what
                > does this mean??
                > Thanks

                Oops, sorry wrong link on the clipboard...
                http://www.adobe.com/livedocs/flex/3/html/help.html?content=05B_Security_04.html