6 Replies Latest reply on Nov 10, 2006 5:32 AM by Newsgroup_User

    character problem please help

    Level 7
      Hi

      This has become an urgent problem today, please could someone shed some
      light!

      I am having problem with the character "Ö"

      Flash seems to think that this has the urlencoded value of %C3%96

      but when I use server.urlencode in my asp page that supplies the value, it
      sends %D6 which flash renders as a square!

      Please could anyone shed some light on this, this is really urgent now!

      Many thanks


        • 1. Re: character problem please help
          arunbe Level 1
          i cant get your problem clearly !
          Can you explain briefly ???

          Cool.... :)

          Arun
          • 2. Re: character problem please help
            Level 7
            I use server.urlencode in my asp page to return values to flash.

            When I return the symbol "Ö" into flash it returns as %D6, but flash renders
            this symbol as a square.

            The flash interpretation of "Ö" is %C3%96 which is clearly different.

            Any ideas?

            "arunbe" <webforumsuser@macromedia.com> wrote in message
            news:ej1oh9$lss$1@forums.macromedia.com...
            >i cant get your problem clearly !
            > Can you explain briefly ???
            >
            > Cool.... :)
            >
            > Arun


            • 3. Re: character problem please help
              arunbe Level 1
              hi
              i think, there might be the unicode characters problem.
              So, you just try to send the symbol as unicode from the asp.
              like string="\u00D5". this is turn with flash will show the correcsponding symbol in the text feild.

              Cool... :)

              Arun
              • 4. Re: character problem please help
                Level 7
                I think that may work, but how would i do that in the asp? At the monment i
                use server.urlencode to give it in the form i posted. How would i encode as
                unicode?

                Many thanks

                "arunbe" <webforumsuser@macromedia.com> wrote in message
                news:ej1rdh$p6d$1@forums.macromedia.com...
                > hi
                > i think, there might be the unicode characters problem.
                > So, you just try to send the symbol as unicode from the asp.
                > like string="\u00D5". this is turn with flash will show the correcsponding
                > symbol in the text feild.
                >
                > Cool... :)
                >
                > Arun
                >


                • 5. Re: character problem please help
                  arunbe Level 1
                  Sorry Dava,

                  I am not well in asp.
                  But, you dont need to convert them into unicode something else.
                  Just you send it as string from the asp. ( i dont know is it possible or not in asp).
                  But, this is the one of the way to solve your problem.
                  • 6. Re: character problem please help
                    Level 7
                    I'll try that, thanks for your help
                    "arunbe" <webforumsuser@macromedia.com> wrote in message
                    news:ej1ua1$sj3$1@forums.macromedia.com...
                    > Sorry Dava,
                    >
                    > I am not well in asp.
                    > But, you dont need to convert them into unicode something else.
                    > Just you send it as string from the asp. ( i dont know is it possible or
                    > not
                    > in asp).
                    > But, this is the one of the way to solve your problem.
                    >