8 Replies Latest reply on Apr 5, 2008 3:48 PM by (Joy_Freeman)

    Trouble Scripting InDesign CS while running Leopard

    Level 1
      Hi all,

      I have a bunch of great InDesign CS scripts that worked perfectly in Tiger (OS 10.4), but since upgrading to Leopard (OS 10.5), none of them work anymore. I can script all of my other apps (Finder, Mail, iTunes, TextEdit, etc...) but my InDesign CS scripts refuse to compile when I write them, and previously saved InDesign CS scripts open up with the "action words" as raw code. (Please see below)

      It's almost like the Applescript library for InDesign CS was deleted in the upgrade. Whatever the problem is, I have seen other Leopard/InDesign CS users with the same problem, but know of at least one Leopard/InDesign CS user whose computer does not have this problem. I called Adobe, but they won't help me because I am not using CS2 or CS3, and they suggested I post here instead.

      Has anyone ever heard of this problem or possibly know how to fix it? Any help at all would be greatly appreciated! Thanks in advance.

      Below is an example of a script that creates a document with specified parameters. It works perfectly in Tiger, but here is what it looks like in Leopard:

      tell application "InDesign CS"
      activate
      set targetDoc to make document
      tell «class vwpp» of targetDoc
      set «class hunt» to «class zinc»
      set «class vunt» to «class zinc»
      set «class RCtp» to «constant MRcdRCPo»
      tell «class dcpp» of targetDoc
      set «class qpro» to {«class colc»:1, «class colg»:0.1667, «class mart»:0.25, «class marl»:0.25, «class marb»:0.5, «class marr»:0.25}
      set «class phgt» to 8.25
      set «class pwdt» to 5.25
      set «class pori» to «constant oriehigh»
      set «class ppsd» to false
      set «class bldu» to true
      set «class bldt» to ".125"
      set «class nump» to 1
      end tell
        • 1. Re: Trouble Scripting InDesign CS while running Leopard
          sstanleyau Level 4
          I can't help you other than to say that CS worked fine when I updated my<br />PowerBook to 10.5. What happens if you try to open the dictionary in Script<br />Editor?<br /><br />-- <br />Shane Stanley <sstanley@myriad-com.com.au>
          • 2. Re: Trouble Scripting InDesign CS while running Leopard
            Level 1
            Thanks for the response, Shane, and I am encouraged to hear that this may be fixable.

            That is a great question, and that is exactly the problem. When I try to open InDesign's Applescript dictionary, it's just not there. My other apps and other Adobe products are there, but the InDesign icon is missing. Adobe wasn't able to tell me how I might be able to find or recover a missing Applescript dictionary, and I don't know if it's just a file hiding somewhere or what. But like I said, I've looked on other people's Leopard machines here at work, and they have the same problem.

            If you know how I can recover that dictionary, then I think that may be the most likely path to a fix. I did some Googling on this, but couldn't find anything helpful. Let me know if you have any ideas...
            • 3. Re: Trouble Scripting InDesign CS while running Leopard
              I have seen a similar thing happen with other applications on other OS's. Usually all I had to do to solve the problem was to restart the machine or make sure that the application was active. (I see that's not your case.)

              Maybe Repairing Disk Permissions on the machine might jog the machine into remembering where the library is located. I have used an application called AppleJack that does Permissions and more. I don't guarantee that either of these will help, but it might be worth a try.

              Also you might try reinstalling InDesign, this too may wake up the system to the dictionary.
              • 4. Re: Trouble Scripting InDesign CS while running Leopard
                Level 1
                Hi Hayden,

                Have you tried using Browse to select the InDesign CS library? And, for whatever it's worth, I'm surprised that InDesign CS even runs on Leopard. Even CS3 needs patching to run properly on that OS.

                Thanks,

                Ole
                • 5. Re: Trouble Scripting InDesign CS while running Leopard
                  Level 1
                  Andrew and Ole,

                  First, thanks so much for your help with this. I really appreciate your replies.

                  Andrew, I repaired the disk permissions and tried to open the library again, but it doesn't seem to have changed anything, just as you cautioned. I thought that reinstalling InDesign might also be worth a try an I am waiting on our IT guys to get back to me about that. Hopefully, that will ultimately help.

                  In the meantime, I also followed Ole's suggestion. I opened the InDesign dictionary on a Tiger computer and saw that the name was "InDesign CS.asdictionary". So I went to my Leopard machine and did a spotlight search for anything by that name and two files came up. One file was located in one of Xcode 2.5's folders and the other was in a folder of an application project that I am currently working on. I have no idea how either of them got there, or if that is even the correct place for them to be hanging out, but that is where they showed up in spotlight.

                  I tried to open them both. First, I tried dragging them onto Script Editor's icon in the dock, which did nothing. Then, I tried opening a dictionary in Script Editor and browsing for one of those two found files, but they are not selectable...almost like they are not the right filetype. Finder is saying they are "document" files, but opening them in TextEdit produces a lot of gobbledeegook with a few distinguishable phrases...but obviously still no good.

                  Should I try deleting one of these files? Could they be conflicting with each other? Also, I tried searching for the InDesign dictionary file on a Tiger computer so I could copy it to my machine, but a search turns up nothing.

                  Oh and Ole, I have found CS to be glitchy on occasion since I upgraded to Leopard, but so far it has not been too bad. I have heard of others who have had a lot of problems with CS and CS3, though.
                  • 6. Re: Trouble Scripting InDesign CS while running Leopard
                    sstanleyau Level 4
                    On 20/3/08 2:51 AM, "Olav Kvern" <member@adobeforums.com> wrote:<br /><br />> I'm surprised that InDesign CS even runs on Leopard<br /><br />So was I. But last month I ran a big bunch of CS scripts for an old job,<br />without so much as a hiccup. Quite impressive, it was.<br /><br />-- <br />Shane Stanley <sstanley@myriad-com.com.au>
                    • 7. Re: Trouble Scripting InDesign CS while running Leopard
                      Level 1
                      Hi all.

                      Regretfully, reinstalling InDesign does not seem to have helped. The InDesign Applescript dictionary is still missing from the list of applications when I try to open a dictionary from Script Editor's File menu.

                      Something interesting, though...when I do that and then select to Browse for a dictionary file, I can click on the Adobe apps themselves with the exception of InDesign, which is grayed out. My IT guy is looking into this whole dictionary problem, but I wanted to let you guys know what I've found out.

                      In the meantime, can anyone tell me the actual name of the InDesign Applescript Dictionary file? Also, I would imagine its proper location would be in the InDesign application folder, but can any of you confirm this?

                      Thanks so much for your help!

                      hayden
                      • 8. Re: Trouble Scripting InDesign CS while running Leopard
                        Hi Hayden,

                        When I tried to find the dictionary for my own InDesign CS (running on 10.4.11), it was also missing. After spending quite some time looking for it, I finally used the Browse function to select InDesign itself (InDesign CS.app) and clicked the Choose button, and the dictionary opened. It still doesn't show up in the list, though. Don't know why. Hope this helps.

                        Joy Freeman