1 Reply Latest reply on Jun 8, 2006 3:20 PM by Fernis

    Webservice not registering

    prasanth.t
      After I created a cfc file for accessing easyPDF software and put it as a webservice it is showing error

      like Error creating web service. Please ensure that you have entered a correct Web Service name or URL.

      Our site is a non secure one, is it a problem with SSL?

      The same cfc worked before we tried with the trial version of same software. What is the problem here?
      only change we made after applyinggetting the license key of software we incorporate and executed the cfc.
      Why it happened after registering the software?

      Thanks in advance.
      Hope somebody can tell the reason.


      Code change we made in the cfc
      easyPrinter = CreateObject("Com","easyPdfSdk.Printer");//easyPrinter = easyLoader.Printer;
      easyPrinterSettings = easyPrinter.PrinterSetting;
      easyPrintJob = easyPrinter.PrintJob;
      easyPrintJob.LicenseKey = PDFLicenceKey;
      easyIEPrintJob = easyPrinter.IEPrintJob;
      PDFProcessor = CreateObject("Com","easyPdfSdk.PDFProcessor"); //PDFProcessor = easyLoader.PDFProcessor;
      PDFProcessor.LicenseKey = PDFLicenceKey;

      easyPrinterSettings.LayoutPaperOrientation = orientation;
      easyPrinterSettings.save();

      easyIEPrintJob.MarginTop = margin_top;
      easyIEPrintJob.MarginBottom = margin_bottom;
      easyIEPrintJob.MarginLeft = margin_left;
      easyIEPrintJob.MarginRight = margin_right;
      easyIEPrintJob.header = "";
      easyIEPrintJob.footer = "";
      easyIEPrintJob.PrintBGColor = 1;
      easyIEPrintJob.SaveSetting();
        • 1. Re: Webservice not registering
          Fernis Level 3
          There is a bug in CFMX 7.0.2b3 (and 7.0.1 if I remember right) which prevents you from registering a web service, then deleting it, and then re-register... as well as many other webservice related bugs.

          Try restarting your CF server, and then re-register. Did it help?